We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36830
    • 140 Posts
    I've been trying to update my clients old site from ModX 2.1 to 2.3 all day. I'm currently on a hamster wheel of merge-uploading the new modx (which i've done a thousand times before so no problems there), initiating setup, choosing advanced upgrade (client had to switch servers for a newer version of PHP), successfully connecting to the database through the test then getting an error about "table prefix not found" even though in the database "modx_" is the prefix. Another weird thing — i've dl'd many times thinking that something must have been corrupted on transfer, and the setup screen keeps saying 2.1.3-PL on top (huh?). Also the PHP version that comes up in the setup is wrong. It says 5.0.3 when my version is 5.3.3. Has anyone witnessed this behavior before? Should I step-up to 2.2 first? Any insight would be greatly appreciated. (Incidentally, creating a fresh installation does work, but then I'm unable to pull in the old, clean database).
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Do not try to upgrade with such a difference between the versions.

      First upgrade to 2.2, then try a couple of intermediate version of 2.2 up to 2.2.15.

      You might want to consider leaving it at 2.2.15.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 36830
        • 140 Posts
        will do. thanks.
          • 36830
          • 140 Posts
          Still same database errors with 2.2.0-pl i'm afraid... I'm baffled as to why the setup would pick up the wrong server version...
            • 36830
            • 140 Posts
            Update. Created absolute paths in config.inc.php and everything worked (except still gave me wrong mysql version in setup). Installed but now i'm getting a blank manager page. Compressed js/css set to no. This is 24 hours now trying to set this thing up...
              • 3749
              • 24,544 Posts
              Your symptoms sound like what would happen if some old files are not being overwritten on upgrade, or if one or more files is corrupted or missing. It's fairly common if you transfer the files individually with FTP.

              Before doing anything else, though, log out, manually delete the core/cache directory and visit with an incognito or private window in your browser.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 36830
                • 140 Posts
                Thanks. I'm able to complete a fresh installation of 2.2.0-pl with everything intact, but then when I drop new tables and reimport backup db tables, it's back to the blank manager screen. I'm getting no errors in my database backup at all... The database has to be the culprit; everything else is fine (permissions, paths, etc). However, if the database is coming up clean, where do I go from there?! Could it have something to do with the setup somehow declaring the mysql version as 5.1 when it's truly 5.3? I'm lost...
                  • 28042 ☆ A M B ☆
                  • 24,524 Posts
                  You can't use the old database with the new version's core files. If you try that, you'll need to run the setup again in upgrade mode to update the database table structure.
                    Studying MODX in the desert - http://sottwell.com
                    Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                    Join the Slack Community - http://modx.org
                    • 3749
                    • 24,544 Posts
                    You might also have to lower the settings_version System Setting to convince MODX to upgrade the tables.
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 36830
                      • 140 Posts
                      So it seems that I was mistakenly conflating the MySQL and the PHP versions... The versions stated by the setup is, in fact, accurate. This is (to a limited degree) a heartening discovery but I'm still unable to get a manager after setup... Bob, I'm not seeing a settings_version setting in the database... For now I'm going to assume that my db has somehow been corrupted or is missing tables (even though I'm pretty sure it isn't) and try to get an older version from the host.