On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Evo 1.0.12
    I have a strange problem with friendly URL's. I have set them to ON but they don't show.
    (I am pretty sure) the .htaccess is configured correctly. There is only one .htaccess in the root directory.
    I have cleared the cache and tried viewing the site in different browsers while being logged out.
    All pages have an URL alias set.

    However, by default, the URL's are showing the /index.php?id=1 and not the URL alias.
    Oddly, when the URL alias is entered into the browser it works and the friendly URL shows.
    When any link is selected, it reverts back to the unfriendly /index.php?id=1 type URL.

    The site is http://www.rsacoursemelbourne.com/

    This question has been answered by kp52. See the first response.

    • discuss.answer
      How are you building your main menu? The footer menu is showing the friendly URL version of things.
      :) KP
      • Hi KP
        Aha, that was it, thanks.
        The problem menus were hard coded with index.php?id=1 and not [~1~]
        The footer menus that appeared to work were hard coded with index.html etc.
        Once I changed all the problem menu links to the evo page link tags ie; [~1~] then all worked perfectly.
        Many thanks for your assistance.
        rgds Stephen