We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 48556
    • 3 Posts
    I've recently upgraded a site to MODx 2.3.1 and now my client is getting a 401 Authorisation error on lang.js.php and the full (beautiful) new interface isn't loading properly.

    I've gone through Bob Ray's usual steps, but what's happening is:


    • User can log in - but interface doesn't load fully
    • 401 authorisation error on connectors/lang.js.php
    • User clicks on anything they either get a "You are logged out" popup or go back to login screen

    The weird thing is, this isn't happening from my location, only the clients. Could it be that they have a proxy in place that's somehow getting in the way? I added a no cache headers via .htaccess. Or could it be an Apache issue?
      • 3749
      • 24,544 Posts
      Did you have the client clear their browser cache and cookies (or go incognito/private)? It sounds like a leftover cookie, or a browser cache issue.

      I assume that you have compress_js and compress_css off.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting