On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • After upgrading one of my sites to 2.3.1 I'm getting this error:

    Code: 200 OK
    {"success":false,"message":"Processor not found: getlist","total":0,"data":[],"object":[]}


    every time I select a resource or an element that attempts to build a list. I'm logged in as Administrator and I have all 172 permissions granted to me.

    I went into package management, and there were no packages present, just the message:

    Processor not found: getlist

    I deleted core/cache and this allowed me to see packages, but did not fix the other issues

    Looking at the error log, I see many errors. For example:

    [2014-07-29 11:21:11] (ERROR @ /connectors/workspace/packages-rest.php) Processor /var/www/hca/core/model/modx/processors/getlist.php does not exist; Array
    (
    [action] => getlist
    )

    [2014-07-29 11:21:11] (ERROR @ /connectors/workspace/providers.php) Processor /var/www/hca/core/model/modx/processors/getlist.php does not exist; Array
    (
    [action] => getlist
    )


    However, most of the errors are for extenduser, a component I had written before the upgrade to extend Moduser:

    [2014-07-29 11:44:59] (ERROR @ /connectors/index.php) Path specified for package extenduser is not a valid or accessible directory: /var/www/hca/core/components/extenduser/model/model/

    Note the extra /model directory.

    The plugin that uses this was deactivated before clearing out the cache.

    I suspect I might have two different issues here, but I can't be sure. The front end of the site is fine, it is just the Manager having issues. Sorry about the amount of detail - I try to be thorough.

    Help please!

    This question has been answered by gissirob. See the first response.

    • I have some ideas. One is the extension_packages System Setting. The docs say that the core path there should be {core_path}, but in my testing, only [[++core_path]] has worked.

      If the plugin is disabled, you could delete the extension_packages value for that package.

      In addition, 2.3 has a new table: modx_extension_packages. First, you may not have that table -- I've seen reports of upgrades where the DB didn't get modified properly (another thing to check is that in 2.3, the modx_context table should have a 'name' field). Second, maybe there's a record for the disabled plugin in the modx_extension_packages table. This is likely if you ever ran ClassExtender (the new version will remove that record -- can't remember if it's released yet). If so, removing it will probably help.

      Finally, check the class_key of all your resources to make sure it's modDocument.

      See this also: http://forums.modx.com/thread/92206/error-code-200-ok-on-every-resource-select?page=2#dis-post-504993

      Deleting all files in the core/cache directory and clearing your browser cache and cookies is also worth a try. [ed. note: BobRay last edited this post 6 years, 1 month ago.]
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • Thanks Bob, you're (almost) a genius. smiley

        Deleted the the extension_packages value for the package & deleted core/cache. No change.
        Removed the relevant line from modx_extension_packages & deleted core/cache. That fixed the hundreds of extenduser errors.

        (BTW, this package pre-dates your ClassExtender add-in. I'll be using that in future as I never quite got mine to work)

        So I clearly have two problems (well, one now). My other issue, the Code 200 error is still happening. I can be fairly certain that it's only occurring when I try and load a resource or element that has a drop-down list in it (such as the "Uses Template" drop-down). This makes sense given the error. When I look in the filesystem, the error is correct, /var/www/hca/core/model/modx/processors/getlist.php does not exist (it is one directory level lower).

        What next?
        • First, make sure your users have modUser as the class_key.

          There are lots of getList processor files below core/model/modx/processors/. You're clearly having trouble with more than one. I think if it weren't finding *any* of them, you'd be having more serious trouble, but I could be wrong.

          Check the MODX_PROCESSORS_PATH in core/config/config.inc.php. If that's wrong, it could explain the whole thing. If not, it will take some serious digging to find the problem. BTW, you're not the only one reporting this.

          [Update] Another user reported fixing this by deleting all files in the core/cache directory and viewing the site in an Incognito window. If that works for you, deleting the cache files and clearing the browser cache and cookies should fix things.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
          • discuss.answer

            [Update] Another user reported fixing this by deleting all files in the core/cache directory and viewing the site in an Incognito window. If that works for you, deleting the cache files and clearing the browser cache and cookies should fix things.

            That fixed it (clearing the browser cache that is). I had previously cleared the modx cache (by deleting core/cache) so I'm not sure whether both are required.

            Many thanks for saving my life yet again.

            Robert.

            PS: Sorry to keep bothering you, but I'm back to my first issue: I'm now getting this error: (ERROR @ /connectors/index.php) Could not load class: extUser from mysql.extuser. This is the extenduser class. Is there a setting I need to change to stop this or do I just delete the class from the filesystem?
            • Deleting the class wouldn't help. You need to get rid of the registered extension_package.

              1. Make sure all users in the DB have the class_key modUser.
              2. Remove any extendedUser records from the modx_extension_packages table in the DB.
              3. Remove the extendedUser part of the extension_packages System Setting.

              These may not all apply, but at least one of them should.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
              • Hi Bob,

                I had already done all three of your suggestions (and cleared cache) before the errors popped up. However I have not received any more since so I'm going to put it down to a timing aberration and move on. Many thanks again for all your help.
                • I'm glad I could help. smiley
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                  • Hi

                    i had same error.

                    I found a solution editing one plugin code here : public_html/assets/components/articles/js/article/update.js

                    Changing the line
                    process: (MODx.config.connector_url) ? 'resource/update' : 'update'
                    by
                    process: 'resource/update'

                    After cleaning all caches it works fine.

                    NB: other plugin in your case might be in cause. Try to look for 'update' in the assets directory of your site, and check for all occurrence.

                    I hope it can help somebody.
                    • Quote from: hedonie at Feb 25, 2016, 08:50 PM
                      Hi

                      i had same error.

                      I found a solution editing one plugin code here : public_html/assets/components/articles/js/article/update.js

                      Changing the line
                      process: (MODx.config.connector_url) ? 'resource/update' : 'update'
                      by
                      process: 'resource/update'

                      After cleaning all caches it works fine.

                      NB: other plugin in your case might be in cause. Try to look for 'update' in the assets directory of your site, and check for all occurrence.

                      I hope it can help somebody.

                      Hi - Can you give me some more guidance on your fix as I don't follow how you got it working. Many thanks.

                      dubbs.