-
☆ A M B ☆
- 24,524 Posts
The included Amazon S3 media source type displays the lexicon items in its Media Source configuration fields. However, the Swift (OpenStack Object Storage) driver, which is based on the S3 driver, does not display its lexicon items there, although they are used in other areas. Any ideas as to what the problem is?
[ed. note: sottwell last edited this post 12 years, 2 months ago.]
-
☆ A M B ☆
- 24,524 Posts
Ok, I solved the problem with good ol' trial-and-error. In the function for generating the default properties you need to load the relevant lexicon. I don't know why the S3 driver doesn't need to do so.
public function getDefaultProperties() {
$this->xpdo->lexicon->load('swift:default');