We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 48274
    • 2 Posts
    Hello. An error occurs when you try to delete a user. error: An error occurred while trying to delete a user.
    The error log:
    [2014-07-10 10:59:31] (ERROR @ /connectors/security/logout.php) xPDO->removeObject - Error deleting modDbRegisterMessage instance using query DELETE FROM `modx_register_messages` WHERE  ( `modx_register_messages`.`topic` = 1 AND `modx_register_messages`.`id` = '12312313123123131231231231313123' )  
    


    But that's not all, when you delete a user from a group, it is not removed from the group, and once again it added.


    The error log:




    I'm using MODX Revolution 2.2.14-pl
    Update modx does not help, I suspect that the problem with the rights. Help please.

    This question has been answered by BobRay. See the first response.

    [ed. note: okkapi last edited this post 12 years, 2 months ago.]
    • discuss.answer
      • 3749
      • 24,544 Posts
      It looks as if the user of your database specified in the core/config/config.inc.php file does not have full rights to the database. This can only be fixed in the database section of cPanel (or the equivalent).

      You may have to do some manual operations on the DB after fixing this if there are really duplicate records there. The original admin's ID should be 1, BTW.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 48274
        • 2 Posts
        Thank you, and so it proved. Database user does not have permission to remove it.