On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hello

    I'm using Modx Revolution 2.2.

    I have created a new user using the Administrator policy template. The only think I have deselected is access to the Element tab. (Although have also tried with that enabled and get the same result).

    All is working well except.... the user can't edit template variables which contain images. When they first open the page they can see the url of the image in the template variable but they can't edit it. When they go to save a page the link to the images disappears, and the image has gone from the page. They are able update and save Template Variables which are text fields, this only applies to those which have images in them.

    I've retraced my steps many many times to try and see if there is a simple mistake, and have played around with various settings but I'm stuck now as to what could be causing this. Happy to share the user access details if you are able to help but any pointer in even the general direction of something that might help would be great. I've been playing around with permissions and users for 2 days and its starting to get a little frustrating now.

    Thanks in advance
    Naomi

    [ed. note: meemal last edited this post 4 years, 11 months ago.]
    • Do you have any Element Category Access ACL entries?
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • OK, so in the end the solution was simple, though not immediately obvious.

        I had previously created a media source for the new user to see the filesystem as they couldn't otherwise see the files. But, the Template Variable was set to use the filsystem as media source. I had to change that to the new media source which I had created for the new user to see.
        • Hi meemal,
          Excuse me the question dates a bit but I have exactly the same problem as you and I did not understand how you did to solve it. Can you explain to me how you did it?
          Regards
          • FYI, I believe the wiping of the TV values was a bug that's been fixed.

            More important, there are a number of serious security vulnerabilities in MODX 2.2 and a tendency for the cache to get corrupted. I'd recommend upgrading as soon as possible because MODX sites are currently under attack with a very widespread hacking effort.

            When upgrading, don't skip the major releases (iow, upgrade to 2.3.0, 2.4.0, 2.5.0, 2.6.0, then 2.6.5).
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
            • Hi BobRay,
              I am a beginner and I use version 2.6.5. I realized by creating a user manual of my site that the users could not edit the image template variable anymore as on the attached meemal file. As I created a Media Sources near the end of my site configuration, I realized that I should have done it at the beginning and before the creation of ten pages articles because now I do not know what to do for that my users find the possibility of editing the TV picture variable...
              • Hi,
                I finally solved the problem of editing TV by users by carefully following the two documents below. Thank you very much.

                Creating a Media Source for Clients Tutorial

                https://docs.modx.com/revolution/2.x/administering-your-site/media-sources/securing-a-media-source/creating-a-media-source-for-clients-tutorial

                Assigning Media Sources to TVs

                https://docs.modx.com/revolution/2.x/administering-your-site/media-sources/assigning-media-sources-to-tvs