We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 9995
    • 1,613 Posts
    What do I need to do?

    Installation error message:
    Setup will now attempt to setup the database:
    
    Creating connection to the database: OK!
    Selecting database `xxxxxxxxxxxx`: OK!
    Creating database tables: Database Alerts!
    
    MODX setup couldn't install/alter some tables inside the selected database.
    The following errors had occurred during installation
    
    Column 'description' cannot be part of FULLTEXT index during the execution of SQL statement ALTER TABLE `modx_site_content` MODIFY COLUMN `pagetitle` varchar(255) NOT NULL default '', MODIFY COLUMN `alias` varchar(255) default '', MODIFY COLUMN `introtext` text COMMENT 'Used to provide quick summary of the document', MODIFY COLUMN `content` mediumtext, MODIFY COLUMN `menutitle` varchar(255) NOT NULL DEFAULT '' COMMENT 'Menu title'.
    
    Some tables were not updated. This might be due to previous modifications.



    Do I need to change database collation or change the mediumtext into full or something??
    [ed. note: fourroses666 last edited this post 12 years, 2 months ago.]
      Evolution user, I like the back-end speed and simplicity smiley
      • 9995
      • 1,613 Posts
      PHP Version 5.3.17
      MYSQL 5.5.28
      upgrade: 1.0.6 -> 1.0.14

        Evolution user, I like the back-end speed and simplicity smiley
        • 9995
        • 1,613 Posts
        THIS FIXED IT: (changing the utf8 collation to swedish like all others)

        ALTER TABLE `modx_site_content` DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci
          Evolution user, I like the back-end speed and simplicity smiley