I am received the the following error message when using phpthumbof;
[2014-07-03 22:51:39] (ERROR @ /home/warrensb/public_html/new/revo/core/model/phpthumb/phpthumb.class.php : 1403) PHP warning: getimagesize(/home/warrensb/public_html/new/revo//new/revo/assets/media/Shop-Images/Large-Steak.jpg) [<a href='function.getimagesize'>function.getimagesize</a>]: failed to open stream: No such file or directory
"/new/revo/" is being duplicated within the getimagesize path. How do I resolve this path issue?
Hi guys, any suggestions? Where are these paths set?
This error seems to be effecting all Revo site installed on my server.
Are there any likely server config settings which could course such headaches.
Server config below:
MODX Revolution 2.2.14-pl (traditional)
PHP Version 5.3.28
Database version: mysql 5.1.68-cll
My hosting company has located the issue. It seems that there is a problem with phpthumbof when installed within a sub directory.
I have posted the hosting company feedback below:
"As mentioned in the last message the problem line occurs when the script appends these two variables: $this->config_document_root and $filename. The script is setting the config_document_root incorrectly and this appears to be an issue many people have had with the script for years. The "fix" was to replace $this->config_document_root with $_SERVER['DOCUMENT_ROOT'] which also proves that the server's configuration is correct."
"The file changed was /home/xxxx/public_html/revo/core/model/phpthumb/modphpthumb.class.php line 262."
"The issue isn't specific to clook servers, this is apparent by the fact that a number of people have had this issue for years. The issue is that you've installed it into a subdirectory and that causes these issues. A quick google search of the issue led me to the modx thread that reaches back several years and also contained the solution to this problem."