Getting the following when trying to upgrade from 2.2.7 to 2.2.14 - this happens when I try to log in to the manager for the first time. Front end just shows 'Access denied':
Fatal error: Call to a member function hash() on a non-object in /homepages/41/****/htdocs/*****/core/model/modx/moduser.class.php on line 237
Any ideas?
What if you manually delete everything in the core/cache/ directory. And also make sure that all of your browser cache and cookies are deleted for the entire domain.
Thanks for your reply Andreas.
I did all that over and over.
What I've now done is a slightly different upgrade path. I did a clean install of Revo then uploaded the necessary assets, then replaced the contents of the newly created database with the old content. This worked much better.
The only problem I seem to have now is that my galleries have got 'lost'. They are all there in the Gallery component but I get the following error in the front end:
Fatal error: Cannot use string offset as an array in /homepages/41/******/htdocs/*******/core/cache/includes/elements/modsnippet/42.include.cache.php on line 144.
Tried re-saving each gallery but in the back end I get error:
Album not specified. - when trying to save any gallery.
Reinstalled Gallery and now working