On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • argh - Just discovered this problem as well.
    Its a bit frustrating actually.
    I have quite a few friends who who Quick Manager...
    I upgraded from 1.09 to 1.0.13 and none of em work with it now.
    Tried a fresh install in fact on also and it also does not even work there - (which I assume is why the default insall is "disabled" ? 0

    I absolutely appreciate continued work on Evolution.
    Please share any progress on this Ill keep digging too -

    • Well.. I cant seem to get it to work unless I roll back to 1.10 and even then I cant use modal. ..(although this latter may be a script conflict) . Is there perhaps something in managermanager that has changed significantly?
      • Did you check the source? On a fresh install its not working? Even on a blank template?
        If there are more than one jquery scripts or if you use mootools it might conflict.

        (I never use QuickManager anymore)
          Evolution user, I like the back-end speed and simplicity smiley
        • Quote from: DfX at Sep 02, 2014, 12:30 AM
          Well.. I cant seem to get it to work unless I roll back to 1.10 and even then I cant use modal. ..(although this latter may be a script conflict) . Is there perhaps something in managermanager that has changed significantly?

          Upgrade to 0.6.x was significant, indeed:
          • I know the old name for the mm rules chunk changed from (old)mm_demo_rules to (new)mm_rules, that may be why there is a double loading issue. Check the mm configuration options perhaps.
              http://frsbuilders.net (under construction) forum for evolution
            • Thanks Gonna focus on the MM for a bit and also see if my tempalte has too many scripts that may be conflicting. However I do think QuickEdit is invaluable for many of my clients/friends. Its far easier to edit from the front end wits spots that have been designated for them as editable, but I concede it certainly is not a deal breaker..
              I wonder does anyone have QuickeEdit working on at all on 1.12 and above?

              WIll dig further - Thanks!
              • Try to enable/disable "Load jQuery in manager" and "Load jQuery in front-end" and try all combinations.

                Changing these settings, depending on the site and the template, I always solved my QM issues
                  Free MODx Graphic resources and Templates www.tattoocms.it

                  MODx IT  www.modx.it

                  bubuna.com - Web & Multimedia Design
                • Thanks,

                  ok got it mostly working...
                  I messed with the plugin execution order (on doc form render etc), I made sure that same jquery is being called. I disable - load JQ in front en and No-COnflict mode in QM
                  So now it nearly works...the edit window pops up..I make an edit...then save - when I save--I get an error.. However--despite the error- the edits TAKE. So now it has something to do with the redirect..i think.

                  (Local test install on wamp)

                  « MODX Parse Error »
                  MODX encountered the following error while attempting to parse the requested resource:
                  « `` is not numeric and may not be passed to makeUrl() »
                  Basic info
                  REQUEST_URI : ""modx-1.13/manager/index.php
                  Manager action : 5 - Saving resource
                  Current Plugin : Quick Manager+(OnDocFormSave)
                  Referer : http://localhost/modx-1.13/manager/index.php?a=27&id=1&quickmanager=1
                  User Agent : Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36


                  1 include_once()
                  manager/index.php on line 299
                  2 DocumentParser->invokeEvent()
                  manager/processors/save_content.processor.php on line 632
                  3 DocumentParser->evalPlugin()
                  manager/includes/document.parser.class.inc.php on line 3393
                  4 eval()
                  manager/includes/document.parser.class.inc.php on line 994
                  5 Qm->Qm()
                  manager/includes/document.parser.class.inc.php(994) : eval()'d code on line 26
                  6 Qm->Run()
                  assets/plugins/qm/qm.inc.php on line 49
                  7 DocumentParser->makeUrl()
                  assets/plugins/qm/qm.inc.php on line 116

                  ..I just posted the above in case it looks familiar to anyone..as I dig to resolve the redirect issue..
                  • OK This perhaps isnt the best fix (for the save on render issue) but around line90...
                    on qm.inc.php
                    I reverted two lines (which deal with saving docs) to the previous version of qm.inc.php

                    So I reverted from:
                        $_REQUEST['id'] = $e->params['id'];
                                        $key =  $_REQUEST['id'];

                    to previous

                       if(intval($_REQUEST['quickmanager']) == 1) {
                                    $id = $e->params['id'];
                                        $key = $id;

                    So Everything seem to work now with QM. I don't think this effects anything but QM so I may just leave it that way. But perhaps there is another more reliable solution in the future. wink

                    Thanks. And thanks again for support/Development on EVO!
                    • p.s

                      I also think I found a typo..I think..not sure if it did anything but I did change this as well ,,,
                      In the 1.0.13 release of modx the qm inc line 114-

                      114:      $this->modx->sendRedirect($this->modx->makeUrl($id).'?quickmanagerclose=1', 0, 'REDIRECT_HEADER', 'HTTP/1.1 301 Moved Permanently'); 
                      116:                        $this->modx->sendRedirect($this->modx->makeUrl($id).'&quickmanagerclose=1', 0, 'REDIRECT_HEADER', 'HTTP/1.1 301 Moved Permanently');

                      changed (corrected?)