We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 46198
    • 15 Posts
    Good morning!

    I've upgraded an Evo installation to 1.0.14 over the weekend; it went pretty well, but I do have issues with the manager.
    I am not able to save resources after editing unless I hide line 977 for the "document.parser.class.inc.php" file under "manager/includes" :
    eval($pluginCode);

    Once I do that, I have no issue with the manager, but I can't use the frontend for editing. And I don't think it's a good thing to have to hide commands in order to get the thing to work!
    I am not a programmer, so can someone please help me with this issue because I have no idea why this is happening.


    Thanks!

      • 2762
      • 1,198 Posts
      Quote from: normluck at Jun 25, 2014, 07:17 AM
      Good morning!

      ...I am not able to save resources after editing...


      Can you explain the error?
      Server configuration?


      Quote from: normluck at Jun 25, 2014, 07:17 AM
      but I can't use the frontend for editing
      Issue with quick manager?
        Free MODx Graphic resources and Templates www.tattoocms.it
        -----------------------------------------------------

        MODx IT  www.modx.it
        -----------------------------------------------------

        bubuna.com - Web & Multimedia Design
        • 46198
        • 15 Posts
        Quote from: banzai at Jun 25, 2014, 08:02 PM
        Quote from: normluck at Jun 25, 2014, 07:17 AM
        Good morning!

        ...I am not able to save resources after editing...


        Can you explain the error?
        Server configuration?

        Error is very simple; after I've edited the content of a page, clicking the SAVE button does not do anything.
        I will have to ask the IT person for the server configuration, but 1.0.6 was working fine before the upgrade.


        Quote from: normluck at Jun 25, 2014, 07:17 AM
        but I can't use the frontend for editing
        Issue with quick manager?

        Possible, but that is where I have no idea.
        The Evo install was done before I started working with that client, I was hoping to never have to upgrade it and rebuilt a new site with Revo. Point is that I am not knowledgeable at all when it comes to Evo.
          • 46198
          • 15 Posts
          No one can help?
            • 1343 ☆ A M B ☆
            • 2,213 Posts
            Hello,

            We need more information from you in order to help. As Banzai requested, if you could tell us about your hosting environment (ex: GoDaddy Shared Hosting).

            In regards to the error, my gut is leaning toward a corrupt file, in which case uploading the files (MODX) again should help.
              Patrick | Server Wrangler
              About Me: Website | Tweets |  MODX Hosting
              • 46198
              • 15 Posts
              Hello!

              The hosting is done here at my client, with their own server.

              I've removed all plugins and started to reinstall them one by one.
              I have "unhidden" line 977 in document.parser.class.inc.php and am now able to save in the manager and use the frontend.
              Now I have to figure out why TinyMCE is not showing up in my "Editor to use" when I chose to use an editor!

              Thanks!
                • 46198
                • 15 Posts
                Ok, TinyMCE never got resolved, the installer kept giving a "Can't connect to database" error (dbapi.mysql.class.inc.php) so I trashed it and installed CKEditor.

                All is now good with my install.

                Thanks!