We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 24518
    • 9 Posts
    Just finished the update to 1.0.14 and I can no longer see the "front end" of the website. The manager is viewable. Previously I have updated the site several times (the original build was pre 1.x) and never experienced this issue. Before I roll it back, I thought I'd ask if anyone knew where I should start looking.

    TIA!
    Rat
      • 9995
      • 1,613 Posts
      did you try setting off friendly urls? or checked your .htaccess ?
        Evolution user, I like the back-end speed and simplicity smiley
        • 20413
        • 2,877 Posts
        + Try disable plugins, snippets [/!... and check mgr logs for errors.
          @hawproductions | http://mrhaw.com/

          Infograph: MODX Advanced Install in 7 steps:
          http://forums.modx.com/thread/96954/infograph-modx-advanced-install-in-7-steps

          Recap: Portland, OR (PDX) MODX CMS Meetup, Oct 6, 2015. US Bancorp Tower
          http://mrhaw.com/modx_portland_oregon_pdx_modx_cms_meetup_oct_2015_us_bancorp_tower
          • 13428 ☆ A M B ☆
          • 1,031 Posts
          Blank pages are often caused by plugin errors. Any hint in MODX system log? You could disable all plugins and check which one causes this.
            • 24518
            • 9 Posts
            Thanks all! Here's what I tried...
            .htaccess looks good
            I disabled most of the plugins (still need to try all)
            Logs pointed to a SQL Error

            Unfortunately, the site was down too long and I had to revert it to the earlier version. I am going to try to update it later this week and see if I have better results.

            Thank you!
            KO
              • 9995
              • 1,613 Posts
              I have updated 50 sites last week, (most on the same hosting).

              I didn't have allot of problems. There where 3 sites on MijnDomein hosting and needed to set safe_mode off at their controlepanel. Beside that not much problems actually. (KCFinder didn't work)

              There was 1 hosting with PHP 5.1 (lol).
              So updating that site gave problems.

              There was also 1 site where prolly some files failed uploading with FTP, reuploaded 1.0.14 en reinstalled worked, could also be an option althought I really think some plugin/snippet is failing on your site.

              You also could duplicate the database and site on a subfolder which you upgrade.
                Evolution user, I like the back-end speed and simplicity smiley
                • 24518
                • 9 Posts
                Great info. I really appreciate it fellas!
                  • 12943
                  • 97 Posts
                  Kind of what fourroses666 says. I think you have a "white screen of death" probably some php or settings. Check MODx logs or serverlogs. If you've tangled with htaccess or apache config, doublecheck those directives too.

                  Maybe config-file too tight? Meaning, system should be able to Read that ;-) Maybe trash cachefiles if coming from a copy with old stuff. Maybe your upload went laggy? Can't hurt to place your configfile outside manager folder and then replace that folder from install-zip. Maybe do assets too while you're at it.

                  As already mentioned, comment out your own stuff ( with # ) until you'll near the start/end of errors. Every Evo higher than 1.0.9 imo preferably needs php 5.3+ Well, some 5.1.6 of mine left me in the dark once on a 1.0.10 install :-/

                  To finish, check if you connect to dbase. Maybe some characters in password need escaping when in php string? Check everything smiley Set your php-errorlogging to the domainspace where your site runs. This gives you (and reachable to others) a per site overview of problems.
                    Accelerate your Windows system with 9.8 m/s2.