$placeholders['dashboard'] = $this->dashboard->render($this);
I found a coder that tries to help me out - He found out that the dashboard table had been empty and filled in this:
INSERT INTO `modx`.`modx_dashboard` (`id`, `name`, `description`, `hide_trees`) VALUES ('1', 'Default', NULL, '0');
So far, the former errormessage about the welcome.class.php got away, the dashboard showed up but now it shows up everytime - even when I click "Snippets" or "Chunks" to open it just shows up the dashboard

so it's clear that it's the fault of the database to be corrupted. Hope that helps
Edit1:
So far, I we were able to update .9 to .14 and inserted the old database - nothing really changed to functionality of the system. It seems that we could now open the dashboard, also the templates show up and are editable, but "Chunks", "Snippets", "Plugins" /manaare even not editable nor creatable.
The installed "QUIP" also throws an error when opening it up and the most weird thing is that the navigation of the modX manager is completely corrupted and doesn't show up every link which shows up in another modx installation of a well running site of me (version .10) - the "system" link is not showing up, but every content is executable in the browser by copy paste it from the running version (--> /manager/?a=70 for example)
I don't know if this has something to do with all the trouble but I think that Quip is the bad guy here. Also when I try to watch the content of "Components -> Quip" it tells me "Notice: Undefined index: debugUser in .../core/components/quip/model/quip/quip.class.php on line 132"
I really need a good advice here because I owe this website to a really good friend. It has so much content in it so that I am not able to set it up in a complete new version. Hopefully my list of details will bring the solution to somebodys mind. All I am able to invest is about ~30$ which I have in Paysafecards.
If you are not able to see a solution, I thank you in advance for all your help.
Edit2: "500 Error - Site temporarily unavailable." after doing update to .14 the 5. time...config.inc.php has right information filled in but nothing seemes to work - upgrade said "everything okay" and after I clicked "Next" it says the 500 Error. I'm out of ideas. Hopefully u have some left...
Edit3: Edited the config.inc.php and changed the host from "localhost" to "127.0.0.1" - site shows up but no changesto the main problem, also that links in the managerpanel (dropdown main links) not show up is weird - hopefully not everything I did is lost now
Heiko
[ed. note: plemmi last edited this post 12 years, 3 months ago.]