We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3749
    • 24,544 Posts
    You might also try deleting all files in the core/cache directory, if you haven't already. Sometimes a cache file gets corrupted and causes trouble. After clearing the browser cache and cookies, it's a good thing to try when a working site stops working with no changes.
      Did I help you? Buy me a beer
      Get my Book: MODX:The Official Guide
      MODX info for everyone: http://bobsguides.com/modx.html
      My MODX Extras
      Bob's Guides is now hosted at A2 MODX Hosting
      • 46421
      • 16 Posts
      Quote from: sottwell at Jun 08, 2014, 01:01 AM
      Hm. It uploads to the same location where you have the install.php script, so it needs to have write permissions to that directory. That depends on your hosting configuration.

      If install.php doesn't work, then you'll need to upload the MODX files yourself. The best way would be to upload the zip file with your hosting control panel's file manager, unzip it there, and if necessary move the files into place.

      Thank you. I did that the last 3 hours. I put the right parts in place, ran the "/setup" and chose "update"...I haven't got it working. Same error after the Update first said "everything done" and then got an error on the next page.

      Can you likn a step-by-step tutorial for noobs like me? By the way, I have nginx server set up by my old coder. The guy left me and from that time on, I am kinda helpless without explicit tutorials.

      Edit:
      ...I am really frustrated...after setting the htpdocs folder to 777 the "install.php" ran but then stopped and told me "File not found." - It has made some changes on the FTP but I really don't know what to do now. I accidently told my Filezilla to CHMOD every folder to 777 now I could really need a list with the right CHMODs for the files...Oh damn...

      Edit2:
      Install seemed to have worked...the setup folder was created. The "/install.php?modx=revo2.2.14-pl" told me "File not found." Now I ran /setup manually and it seemed to work .... It got through all steps and then told me this on that URL /setup/index.php?action=complete it told me that there has been an error (500) and now my index.php just tells me "Parse error: syntax error, unexpected '{' in .../dev/httpdocs/core/config/config.inc.php on line 13"

      so weird :/

      Edit3:
      sottwell...thanks for your help I will try to get my old backup working and redo every step again, the list with CHMODs would be helpfull - other support would be waste of time at the moment I think. Thank u [ed. note: plemmi last edited this post 12 years, 3 months ago.]
        Please note: I am just a small designer with high interest in ModX - Don't blame me for being newb in IT-things - Thanks for all your help <3
        • 3749
        • 24,544 Posts
        If 777 doesn't work, the odds are that some form of suPHP is running and that you need 755 for folders and 644 for files.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 46421
          • 16 Posts
          $placeholders['dashboard'] = $this->dashboard->render($this);


          I found a coder that tries to help me out - He found out that the dashboard table had been empty and filled in this:

          INSERT INTO `modx`.`modx_dashboard` (`id`, `name`, `description`, `hide_trees`) VALUES ('1', 'Default', NULL, '0');


          So far, the former errormessage about the welcome.class.php got away, the dashboard showed up but now it shows up everytime - even when I click "Snippets" or "Chunks" to open it just shows up the dashboard sad so it's clear that it's the fault of the database to be corrupted. Hope that helps

          Edit1:
          So far, I we were able to update .9 to .14 and inserted the old database - nothing really changed to functionality of the system. It seems that we could now open the dashboard, also the templates show up and are editable, but "Chunks", "Snippets", "Plugins" /manaare even not editable nor creatable.

          The installed "QUIP" also throws an error when opening it up and the most weird thing is that the navigation of the modX manager is completely corrupted and doesn't show up every link which shows up in another modx installation of a well running site of me (version .10) - the "system" link is not showing up, but every content is executable in the browser by copy paste it from the running version (--> /manager/?a=70 for example)

          I don't know if this has something to do with all the trouble but I think that Quip is the bad guy here. Also when I try to watch the content of "Components -> Quip" it tells me "Notice: Undefined index: debugUser in .../core/components/quip/model/quip/quip.class.php on line 132"

          I really need a good advice here because I owe this website to a really good friend. It has so much content in it so that I am not able to set it up in a complete new version. Hopefully my list of details will bring the solution to somebodys mind. All I am able to invest is about ~30$ which I have in Paysafecards.

          If you are not able to see a solution, I thank you in advance for all your help.

          Edit2: "500 Error - Site temporarily unavailable." after doing update to .14 the 5. time...config.inc.php has right information filled in but nothing seemes to work - upgrade said "everything okay" and after I clicked "Next" it says the 500 Error. I'm out of ideas. Hopefully u have some left...

          Edit3: Edited the config.inc.php and changed the host from "localhost" to "127.0.0.1" - site shows up but no changesto the main problem, also that links in the managerpanel (dropdown main links) not show up is weird - hopefully not everything I did is lost now

          Heiko [ed. note: plemmi last edited this post 12 years, 3 months ago.]
            Please note: I am just a small designer with high interest in ModX - Don't blame me for being newb in IT-things - Thanks for all your help <3
            • 46421
            • 16 Posts
            I could still need help - or I have to set up complete new ModX and include every content by hand?! What is the best solution in my case now?
              Please note: I am just a small designer with high interest in ModX - Don't blame me for being newb in IT-things - Thanks for all your help <3
              • 3749
              • 24,544 Posts
              The first things to try (if you haven't done them already):

              1. Log out (if you can), then go into PhpMyAdmin in cPanel select all the tables and click on "Repair table"

              2. While you're in the database, go to the modx_system_settings table and change the values of compress_css and compress_js from 1 to 0.

              3. Delete all files in the core/cache directory.

              If none of that works,

              Run Setup again in upgrade mode (upload the setup directory from the exact same version of MODX first if it's not there).

                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 46421
                • 16 Posts
                Thank you Bob! Will try that out today!
                  Please note: I am just a small designer with high interest in ModX - Don't blame me for being newb in IT-things - Thanks for all your help <3
                  • 46421
                  • 16 Posts
                  Did everything - doesn't work. Does the database has to be edited when upgrading? Perhaps I did something wrong there. I created a DB-User with db specific rights (all rights) but no rights for anything else - perhaps thats the mistake?

                  "Run Setup again in upgrade mode (upload the setup directory from the exact same version of MODX first if it's not there)."
                  --> Will try this now and otherwise I will have to redo the complete project I think.

                  EDIT: Have done it - no effect!

                  I have installed ModX .9 completely new and compared the databases. The old database had many entries which were deleted (as like for the Menus of the manager panel) - i copied the new database table modx_menus and replaced the old table --> My menus are back!

                  But...There is DEFINITLY a problem with AJAX. AJAX is used in the manager panel right? So when I open a folder in the left site of the panel the page shows up AND THE FOLDER NORMALLY STAYS OPEN - but it doesn't. It closes everytime and I have to reopen it.

                  That could also be the mistake when I try to open a chunk, snippet, plugin . Nothing shows up on the right side than the dashboard. I am pretty sure that AJAX is the problem but I don't really know how to fix that. Do you have an idea Bob? Or sottwell? [ed. note: plemmi last edited this post 12 years, 3 months ago.]
                    Please note: I am just a small designer with high interest in ModX - Don't blame me for being newb in IT-things - Thanks for all your help <3
                    • 3749
                    • 24,544 Posts
                    Do you see anything in the MODX error log (Reports -> Error Log)?
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting