We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 44416
    • 5 Posts
    Hi I've inherited a MODx install and know very little about it so would appreciate help!

    Up until last two days ago everything was working fine but now although we are able to log in to the manager and make changes but nothing saves - the screen goes into saving mode but we've nothing is happening - even after 5 minutes waiting for it to save. Nothing has been changed at this end but our host has made changed to the server in the past with no notice -- can anyone help with what may be causing this please?


    MODX Version:Revolution 2.2.7
    PHP Version: 5.4.27
    Database: MySQL version 5.5.35-cll
    Apache version 2.2.27
    Installed MODX Add-ons:Slideshow Manager

      • 18373 ☆ A M B ☆
      • 3,141 Posts
      Hi Karen!

      Sorry to hear you're having issues with the site all of a sudden. While it may not be directly related, I would advise you to prioritise a MODX upgrade soon as there are known vulnerabilities in 2.2.7 and your site may be at risk.

      As for the save issue, it sounds like the save request (handled via AJAX) is encountering a fatal error. There may be a few reasons this happens. Does it happen on all pages, or just a group of specific ones?

      There may also be some issues getting logged in the MODX error log, you can check that via Reports > Error Log in the top menu.
        Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

        Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
        • 25803 ☆ A M B ☆
        • 721 Posts
        This can happen when your host turns on Mod Security or they update it. Every-time this has happened I call the host and they whitelabel and disable mod_security and then we can save again.
          • 44416
          • 5 Posts
          It seems to be all of the resources
          A couple of weeks ago we were hacked (yes I do need to do an update but I'm going to have to learn how to do it before I attempt this!) so I changed the manager and controller folder names and the config files as per the Hardening MODx tutorial so you'll see the new folder names in the filepaths on the attached error log - afraid this means very little to me so would appreciate a translation if you can!!
            • 44416
            • 5 Posts
            Quote from: rx2 at Jun 04, 2014, 01:07 PM
            This can happen when your host turns on Mod Security or they update it. Every-time this has happened I call the host and they whitelabel and disable mod_security and then we can save again.
            Thanks for this I'll check as they have a nasty habit of not letting us know when they enable or update core server stuff!!
              • 3749
              • 24,544 Posts
              For the errors in the error log, try this:

              Edit Resources 241, 261, 262, and 263.
              In each one, make a trivial change (like space backspace) to turn on the save button.
              Click on Save.
              Clear the Error Log.

              If that doesn't work, or if you have a lot more errors than you posted, report back and I'll suggest something else.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting