We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 47508
    • 2 Posts
    Hoping someone can point me in the right direction, or at least help me ask the right questions.

    A client has asked me to look into an urgent problem with their MODx site. I've noticed this is actually effecting 2 sites on the same sever, a live account (http://www.eurobodalla.com.au/) and a development account (http://www.eurobodallasandbox.com/). Both have the same symptoms AND manager cannot be accessed (displays the error "That account could not be located. Check the username and re-type the password to try again.")


    I thought that the account/s may have been compromised, but via FTP I can't see any files that have been recently modified. And if I look at the database, there is data visible in the tables. config.inc.php is also pointing the the right database.

    Does anyone have any suggestions for where to look for the problem?


    Thanks!
      • 27708 MODX Staff
      • 2,502 Posts
      Could you detail the symptoms? It's possible that it's been compromised or it's possible that the age of the install and your hosting provider are no longer compatible (i.e. your host upgraded the server software and because MODX is so old it's not working anymore). For a compromise, look for unusual users in the users under Security or check for suspicious plugins. The site is not throwing errors but it could be that php errors are off.
        Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        That looks like just content, no template. Check the template that the home page is assigned to.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 47508
          • 2 Posts
          Thanks Jay.

          My initial thought was that it had been compromised.

          A colleague has stated that "there is something wrong with the connection to the DB"

          Hosting support have stated "mysql service is running fine as expected"

          Via FTP I can't see any files that have been recently modified.

          config.inc.php is still pointing the the correct database, and the password in config.inc.php matches that in an old config.inc.php file (stored locally), so I assume is also correct.

          If the host upgraded the server software causing MODX to stop working, how could you confirm and what would you do (or update) to get it back up?

          Thanks for your help!

          Totally stuck on this.

          PS - waiting for hosting support to also respond.
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            Looks like you're back in business now.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 24629
              • 370 Posts
              You could try to
              first empty the cache, delete everything in core/cache
              second run setup again and check if all pre-install checks are fine.

              RDG