We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38878
    • 255 Posts
    My sites are always "unusual" <_< >_>. I disabled the plugin and the error is still there. Maybe I can just remove it from the system settings and see what that does. Then ModX wouldn't even attempt to load it.

    Quote from: BobRay at Jul 02, 2014, 10:32 PM
    I don't think so. Every time I've tested the uninstall, it has removed everything.

    I'm thinking there must be something unusual about your site, but I can't think what it might be.

    I think the error is occurring in the request handling process and it's happening before any part of ClassExtender is even loaded. So the only role ClassExtender has in this case is writing the value of the extension_packages System Setting, which appears to be correct.

    When the browser requests a page, MODX checks the value of extension_packages and tries to load any packages referenced there. This happens before the page is actually loaded or parsed. I'm pretty sure that's what's failing in your case, and I think the error message is coming from the code that loads stuff specified in extension_packages. IIRC, you said that disabling the CE plugin didn't stop the error, which would be consistent with what I think is happening.

    Even if that's not the case, I think the error would be triggered by the ClassExtender plugin attempting to use the class, which would only fail because it wasn't loaded properly earlier.

      • 3749
      • 24,544 Posts
      Yes, though I don't think ClassExtender will work then unless you create a snippet that loads the clearing the setting altogether and visiting the Extend modUser page again (and opting to register the package).
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 46580
        • 167 Posts
        Same problem with modX 2.3.1

        [2014-08-04 23:05:05] (ERROR @ /manager/index.php) Path specified for package extendeduser is not a valid or accessible directory: ......./core/components/classextender/model/model/

        No double '/model' in 'extension Packages' settings



          MODX lover
          -
          Développeur MODX / Webdesign / Solutions web
          • 3749
          • 24,544 Posts
          2.3 has a new DB table: modx_extension_packages. Removing ClassExtender doesn't clear that (the new version will). Check that table.

            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 39036
            • 28 Posts
            Similar error messages .../model/model/ using rev 2.3.1
            Solved the issue by changing the namespace 'Core Path', removing '/model' for the component through the manager settings menu/Namespaces
              • 3749
              • 24,544 Posts
              @littleseal: Thanks for the report. Another user reported changing the namespace's core path without success. I've never been able to duplicate the problem, so I'm not sure what the deal is. I also don't know how that Namespace path with /model on the end got there in the first place.

              When you say you changed the namespace path, was that the ClassExtender namespace, or the namespace for one of the created object (extendeduser or extendedresource)?

                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 39036
                • 28 Posts
                Hi Bob, Sorry, I should have been more specific, I changed the namespace path for a newly created extendeduser object, all database queries work fine now (i.e. getOne() etc.).
                I initially changed the extension package path in system settings but to no avail, then found the incorrect namespace path.
                I'm not sure how the extra /model popped in either?
                  • 3749
                  • 24,544 Posts
                  Thanks. The strange thing to me is that the sub-objects shouldn't have namespaces at all. The only namespace should be 'classextender'. I'm not sure where any other namespaces would come from.

                  In any event, the new version (2.0) is due very soon and I don't think it will have this problem.

                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 39036
                    • 28 Posts
                    Ah! Now I remember...
                    I did initially use your class extender but then had to alter the tables a few times including different objects so I used the 3rd Party Component Build Script to build the component from the schema in Rev version 2.2.15, I then updated to 2.3.1 and this is why the object has it's own namespace but still not sure where the extra '/model' snuck in?
                    Apologies for the confusion I'd forgotten I took this route!
                      • 3749
                      • 24,544 Posts
                      That makes sense. I actually found one of those namespaces in my own install from when I worked the tutorial in the MODX docs.

                      BTW, ClassExtender 2.0.0 has been released, though you need to read the upgrade notes at Bob's Guides because some things have changed.
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting