We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36782
    • 109 Posts
    [edit]I've changed the title of this post so as to make it more clear what the issue is, as I have made some progress since the original post. I do not intend to 'bump' the thread, in case that happens... I don't think it will though.[/edit]

    Hello,
    I am running modx 2.2.14 but this started happening in 2.2.13. I may have mucked something up in an upgrade - it's an advance install w/ moved / renamed core and stuff.

    I'm on Greengeeks reseller hosting (they are in the recommended hosts list here)
    Running PHP 5.3
    MySQL stuff:
    Server: Localhost via UNIX socket
    Server type: MySQL
    Server version: 5.1.73-cll - MySQL Community Server (GPLv2)
    Protocol version: 10
    User: ****@localhost
    Server charset: UTF-8 Unicode (utf8)

    No suhosin or mod_sec showing up in my config, but it might be lying by omission I suppose...

    Several other MODx 2.2x installations running like butter on this host, so I've obviously done some weird thing to it.

    Here's my error (*the only one in the error log - nothing in Apache error log*)

    --------------------------------------
    [2014-04-27 14:26:26] (ERROR @ /t4m_admin/index.php) Encountered empty IN condition with key usergroup
    [2014-04-27 14:26:26] (ERROR @ /t4m_admin/index.php) Error 42000 executing statement:
    Array
    (
    [0] => 42000
    [1] => 1064
    [2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') OR ( `ProfileUserGroup`.`usergroup` IS NULL AND `UGProfile`.`active` = 1 ) )' at line 1
    )
    --------------------------------------

    NE1 got any hints, ideas, or plain conjecture?
    I can create resources in any context, parents and children. It gets sticky when I try to edit, but not consistently.... once it hangs once, it will always hang on that resource...? WTF?
    Baffled. I really don't want to restore the earliest backup because I'll lose 3 months worth of work sad But I will if I have to. [ed. note: unsub777 last edited this post 12 years, 4 months ago.]
      • 3749
      • 24,544 Posts
      First things to try:


      • Repairing all tables in the DB with PhpMyAdmin
      • Deleting all files in the core/cache directory.
      • Flushing all permissions and sessions.

      If none of that works, you might see if SiteCheck finds anything: http://bobsguides.com/sitecheck-promo.html
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 36782
        • 109 Posts
        Hi Bob,

        Done, done, and done. Alas, I had tried all those things.

        I even went so far as to delete all user_* tables and replace them with the ones from an old (2.2.11) working backup; still can't save - it just hangs interminablly at the 'please wait...'

        Strange discovery though - I can create and save resources on the root of resource tree, just not any child resources smiley LOL well, it will have to do, I'll just move them when I'm done, and move them out when I need to edit.

        Still, sure would love it if someone had an inkling of some kind, I've been at this for hours today, and on-and-off for the past 2 weeks. Thought the 2.2.14 updtate might magically fix it, but no...

        Thanks for your reply Bob smiley
          • 3749
          • 24,544 Posts
          Try turning off the compress_js and compress_css System Settings if you haven't already.

          Another thing to try is to do it with Chrome Dev. tools active (Ctrl-shift-i). See if there are any JS errors and check the network tab. If you click on a file a the left, you can see the processor response on the response tab at the right. Sometimes that will provide a clue to what's happening.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 36782
            • 109 Posts
            Hi Bob,

            I've tried w/ compress_* both on and off, seems like compression finally works on my hosting, because I don't seem to need it off anymore. No difference really.

            I'm going to try the Chrome console this morning - can't believe I overlooked that! wow...

            Thanks very much. Hope i can find something.

            -Gabriel
              • 36782
              • 109 Posts
              aha... it's not finding http://domain.com/connectors/resource/index.php
              which is weird, because it's there, I'm looking right at it.
              so it then goes into a tailspin looking for what it needs at the domain root; it loads all the CSS and JS files from the homepage.

              huh.... And this only happens when saving a child resource, and then only when that child resource has had a problem saving before which is kind of random it seems; or a pattern, at any rate, has been beyond my noticing.

              I will keep poking the nest to see what else flies out. tongue

              -g
                • 3749
                • 24,544 Posts
                That sounds like a server issue, especially since it's intermittent.

                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 36782
                  • 109 Posts
                  it would, but for the 6 other Revo' based sites running flawlessly on it...
                  3 of them standard, 3 of them advanced installs like this one, with custom names / locations for core and connectors.
                  This one uses the same combo of addons as 2 others. It ran really well until I did something wierd while manually changing a user password. So strange. Oh well, if I have to move resources around to edit them, it's still not as bad as having to use Wordpress LOL
                    • 3749
                    • 24,544 Posts
                    There is always this: http://bobsguides.com/sitecheck-promo.html, although generally the problems it finds won't come and go like yours do.
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 35756
                      • 166 Posts
                      Hi unsub777!

                      Did you manage to resovle this issue? I'm having the same problems on two projects I'm working on.

                      Strange discovery though - I can create and save resources on the root of resource tree, just not any child resources smiley LOL well, it will have to do, I'll just move them when I'm done, and move them out when I need to edit.

                      Even this doesn't work for me...

                      I'd be thankull for any hint on this issue.

                      Cheers!