We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 46477
    • 21 Posts
    I’ve got MODx installed on an IIS machine as well as an Apache machine (development)... they both connect to the same database, and at the moment the files and directories are completely identical. In the IIS environment though, only one of the menu items (and it’s sub items) appear, while in the apache install, the menu works correctly.

    Since they run off the same database, the template (as well as the wayfinder call) is identical I can't find the issue.

    No errors are thrown in the php error log or the server log.

    I've also written a couple of custom snippets and neither of these will load either.

    However, every now and then the menu and the custom content pops into the site and then they disappear again...

    We've tried different permission settings as the site wasn't loading or writing to the correct files and now the site has maximum permissions enabled for testing.

    Any ideas?
      • 39404
      • 175 Posts
      stalemate resolution associate Reply #2, 12 years, 6 months ago
      Hi howvard,

      Here are a list of questions to answer that might help us answer better:
      1. Which version of IIS are you running?
      2. Which operating system and version is IIS running on?
      3. Which database and version is IIS connecting to?
      4. Are IIS and the database you're using installed on the same server or different?
      5. Which version of MODX are you trying to install? The latest version if you just downloaded is MODX 2.2.13.
      6. What Extras have you installed in MODX?

      That being said, I can suggest the following things, which are generic in nature.

      I've never tried to install MODX on IIS before, but I have used certain versions of IIS to install other web applications.

      In earlier versions of IIS, you needed to make sure that the directories where you had code to execute had read and execute rights. In later versions of IIS, you had to make sure that you had certain rights set up. Since IIS has changed so much version to version, I don't think that I can say much intelligent without knowing the IIS version.

      On the database side, are you using MySQL or MS SQL Server? In either case, remember that the account that is running IIS supports Windows authentication, so the account that is being used for IIS has to have rights.

      Another thing to consider is PHP versus a MODX installation. I would make sure that you can at least see a PHPInfo screen and run a sample script before worrying about the MODX side.

      Yet another thing to consider is that if the database and IIS are installed on different servers and Windows Authentication is being used, you may have issues because the two servers don't trust each other because they are in different forests and in the request to send code or information across is denied because the request is using Kerberos Delegation.

      In addition to the php, modx and server logs, with Windows machines, some errors are written to the Event Viewer, especially if it has to do with IIS.

      Anyway, good luck and let us know how it goes.

      Regards,
      Tom
        • 46477
        • 21 Posts
        Hi Tom,

        Thanks for your reply, i'll try get the information from the Server admin regarding the IIS version.

        The database is MySQL and Wordpress is currently running on the same db without an issue. I exported this database to my MAMP stack to develop on and then we transferred everything back to the server. We are working on the current version of MODX

        I've just checked again and MODX error log is throwing this up.

        Snippets 5 & 7 are my custom WP feed and WayFinder.

        -------------

        [2014-03-20 13:19:15] (ERROR @ /v3/connectors/system/registry/register.php) Error caching lexicon topic lexicon/en/core/default
        [2014-03-20 13:19:15] (ERROR @ /v3/connectors/system/registry/register.php) Error caching action map mgr/actions
        [2014-03-20 13:19:16] (ERROR @ /v3/connectors/system/errorlog.php) Error caching lexicon topic lexicon/en/core/default
        [2014-03-20 13:19:16] (ERROR @ /v3/connectors/system/errorlog.php) Error caching action map mgr/actions
        [2014-03-20 13:19:24] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/wayfinder/properties
        [2014-03-20 13:19:24] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/wayfinder/properties
        [2014-03-20 13:19:24] (ERROR @ /v3/index.php) Error caching script elements/modsnippet/7
        [2014-03-20 13:19:24] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:25] (ERROR @ /v3/index.php) Error caching lexicon topic lexicon/en/core/tv_widget
        [2014-03-20 13:19:27] (ERROR @ /v3/connectors/system/errorlog.php) Error caching lexicon topic lexicon/en/core/default
        [2014-03-20 13:19:27] (ERROR @ /v3/connectors/system/errorlog.php) Error caching action map mgr/actions

        -------------

        Thanks
        Charles
          • 39404
          • 175 Posts
          stalemate resolution associate Reply #4, 12 years, 6 months ago
          Hi Charles,

          There might be a few issues going on here, neither of which I think relate specifically to IIS. Based on the errors seen here, there might be something wrong with your lexicon files.

          Most likely thought, the thing to look at is the permissions set to the /core/cache directory. I was seeing those kind of permission issues when I was doing some development on WAMP on my local windows machine and the user being used to run WAMP didn't have rights to write to that directory. This would be set in Windows Explorer by right clicking the /core/cache directory and giving read, write and execute to the process which runs IIS and/or under which MODX runs.

          Hope this helps.

          Regards,
          Tom
            • 46477
            • 21 Posts
            Hi Tom,

            Sorry for the delay and thanks for your help.

            We seem to have managed to patch most of the errors. Having done an A / B test against a new server it appears that there is something in the setup of the server that we need to go live on. There seemed to be a permission issue stopping MODX from accessing and deleting cached files. The system admin has manually created the directories and we're now not getting any errors.

            Not quite as straight forward as we had hoped but the site is up and running now.

            Thanks
            Charles