We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 46756
    • 7 Posts
    Greetings,

    I just downloaded the latest stable version of Revo and after upload I encountered this error upon trying to start setup:

    Parse error: syntax error, unexpected '(', expecting ')' in /core/model/smarty/sysplugins/smarty_internal_templateparser.php on line 543


    The line in question in that file is:

     /*   760 */    73,   74,    1, ray(),


    I have no idea what the error is. [ed. note: paryguy last edited this post 12 years, 7 months ago.]
      • 46756
      • 7 Posts
      Not sure what the issue was, I re-uploaded the file in question and the issues has been resolved.
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        It's not unusual for a file to get corrupted during the upload process. It's generally recommended to upload the original .zip file and unzip it on the server, moving files into place as necessary using the server's file manager - often CPanel. Or use an SSH command line.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 46756
          • 7 Posts
          Quote from: sottwell at Mar 03, 2014, 09:14 AM
          It's not unusual for a file to get corrupted during the upload process. It's generally recommended to upload the original .zip file and unzip it on the server, moving files into place as necessary using the server's file manager - often CPanel. Or use an SSH command line.

          That was totally the issue. After I got passed my first issue I encountered issues testing the DB connection info. I just tunneled in and removed all files then unzipped under my root user on SSH and it's all good now. Thanks for the response.
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            I remember the "bad old days" of spending over an hour to upload Evo and then having things fail due to bad files in the upload. The TinyMCE plugin and the core MCPuck file manager were the main culprits with all their fiddly little .js files, not to mention a flaky local Internet service.

            Well, and we had issues with Windows line endings vs the *nix server systems in .php files sometimes... nothing like having your server see a // type comment, and think the whole rest of the file is part of the comment because it never sees a valid end-of-line character.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org