We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 32927
    • 45 Posts
    hi, I tried to change a message [The one that says ’’error while sending mail to’’] in the snippets/weblogin/weblogin.common.inc.php file.
    I use a webhost. I dowloaded the weblogin.common.inc.php file changed it and ftped it back again. then the following error occured

    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:
    « PHP Parse Error »

    PHP error debug
    Error: Unknown: open(/var/lib/php5/sess_f9c56f8a3a961c8bd46ccd8b71bd752e, O_RDWR) failed: Read-only file system (30)
    Error type/ Nr.: Warning - 2
    File: Unknown
    Line: 0

    Parser timing
    MySQL: 0.0032 s (17 Requests)
    PHP: 0.5988 s
    Total: 0.6020 s
    Error while inserting event log into database.


    and then now I can’t log in the manager. this is displayed on the page where I am supposed to log in to the manager


    Warning: session_start() [function.session-start]: open(/var/lib/php5/sess_f9c56f8a3a961c8bd46ccd8b71bd752e, O_RDWR) failed: Read-only file system (30) in /home/pg249/public_html/modx-0.9.6.1/manager/includes/config.inc.php on line 59

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/pg249/public_html/modx-0.9.6.1/manager/includes/config.inc.php:59) in /home/pg249/public_html/modx-0.9.6.1/manager/includes/config.inc.php on line 59

    Warning: Cannot modify header information - headers already sent by (output started at /home/pg249/public_html/modx-0.9.6.1/manager/includes/config.inc.php:59) in /home/pg249/public_html/modx-0.9.6.1/manager/includes/config.inc.php on line 73

    Warning: Unknown: open(/var/lib/php5/sess_f9c56f8a3a961c8bd46ccd8b71bd752e, O_RDWR) failed: Read-only file system (30) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) in Unknown on line 0

    I now can’t log in to phpmyAdmin anymore
    http://dalab.ee.duth.gr/phpmyadmin/

    because the following thing is displayed

    phpMyAdmin - Error

    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

    Pleaaaase help! this is the web site I am trying to do
    http://dalab.ee.duth.gr/~pg249/modx-0.9.6.1/index.php?id=1

    This is very urgent, any help is very appreciated I am very lost!
      * Mathematics, rightly viewed, possesses not only truth, but supreme beauty
      • 25663 MODX Staff
      • 12,272 Posts
      This sounds like your hosts PHP config coincidentally died. Loading phpMyAdmin shouldn’t have been affected by changing the error file.
        Ryan Thrash, MODX Co-Founder
        Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
        • 32927
        • 45 Posts
        so what can I do?
          * Mathematics, rightly viewed, possesses not only truth, but supreme beauty
          • 32927
          • 45 Posts
          I also tried to change the rights of the document to 755 because it wouldn’t replace the old with the new one
            * Mathematics, rightly viewed, possesses not only truth, but supreme beauty
            • 1932
            • 137 Posts
            The issue seems unrelated to MODx/weblogin and is almost certainly a coincidence as Ryan has stated. I would contact your web hosting provider; the session files probably shouldn’t be stored in /var/lib/php5/ and if that’s the intended location, the permissions on that directory are incorrect.

            One possible workaround is to add the following to the end of the file in "modules/includes/config.inc.php" (directly above the ending ?>):

            // Save sessions to a local directory
            session_save_path($base_path . 'assets/cache/sessions/');
            


            Then, you will have to create a new directory under "assets/cache/" called "sessions" and give it full read/write/execute permissions for all groups (chmod 777) using FTP or SSH/telnet.

            This should work provided the session_save_path() function isn’t restricted by your host. Let us know if that helps.

            (I realize you are short on time but for future reference, WebloginPE allows for more functionality and customization than the standard weblogin: http://modxcms.com/WebLoginPE-1593.html)
              • 1932
              • 137 Posts
              If the above method doesn’t work, the only other option I can think of is to place the following in your .htaccess file in the main site directory:

              php_value session.save_path /full/system/path/to/your/website/assets/cache/sessions/
              


              (You will have to create the "assets/cache/sessions" directory and change the permissions as stated above.)
                • 32927
                • 45 Posts
                @rthrash
                @Apoxx

                I guess you are right because I can’t see the other sites (from my co-students, since this is a project assigned to us) that use the same webhost so I think it’s not MoDx related (Thank God!)

                I will contact the provider in a few hours and hopefully everything will be fixed.
                Thank you for your replies, I will post here any news on this matter, in case someone is interested.
                Thank you once again.
                  * Mathematics, rightly viewed, possesses not only truth, but supreme beauty
                  • 32927
                  • 45 Posts
                  Quote from: ganeshXL at Feb 11, 2008, 11:49 PM

                  I would check first if you can CHMOD the /var/lib/php5 directory to 0777.

                  Failing that, define your own via php.ini file or in the config file with
                  @ini_set("session.save_path", ’/your/full/path’);

                  I’d keep that directory outside of root though.

                  Thank you for your reply, but this sounds very dangerous for a newbie like me... If nothing else works I’ll try this out though!
                    * Mathematics, rightly viewed, possesses not only truth, but supreme beauty
                    • 32927
                    • 45 Posts
                    Ok, the problem was in the php configurations of the web host provider. Strange coincidence!
                    Sorry for the false alarm, thank you for your replies.
                      * Mathematics, rightly viewed, possesses not only truth, but supreme beauty