We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 45929
    • 16 Posts
    Hi Everyone,

    I am using MODX revolution for the first time, currently I am developing the site locally within MODX and I am wondering the best method of creating a backup of both the source files and the database? Eventually once my development is complete locally I will be looking towards migrating from local to a live server environment, is that an easy process?

    I am familiar with the WordPress platform and using various utilities / methods for migrating with that platform.

    Your advice would be great.

    Thanks
    Michael
      • 38723
      • 165 Posts
      I always would point people to this link. http://rtfm.modx.com/revolution/2.x/administering-your-site/moving-your-site-to-a-new-server

      Well detailed and should answer most if not all of your questions! I always check back on this guide if I ever forget any of the steps.
        • 22303 MODX Staff
        • 10,725 Posts
        There is also a command-line tool currently in alpha development, called Teleport, that can snapshot the database and files of a MODX site which can then be injected into another MODX installation via Teleport. More information at https://github.com/modxcms/teleport/blob/master/doc/start.md
          • 25803 ☆ A M B ☆
          • 721 Posts
          We currently use Vapor or here.

          It will create a package in core/packages on your local site. You install the same version of MODX your local site is using on the remote server and then take the vapor package and place it in core/packages on the remote server. Then go to Package Management and select "Search Locally for Packages" from the "Download Extras" drop down. It will find the package. Install it.
            • 45929
            • 16 Posts
            Thanks guys , helps a lot.
              • 45929
              • 16 Posts
              Quote from: rx2 at Feb 17, 2014, 08:44 AM
              We currently use Vapor or here.

              It will create a package in core/packages on your local site. You install the same version of MODX your local site is using on the remote server and then take the vapor package and place it in core/packages on the remote server. Then go to Package Management and select "Search Locally for Packages" from the "Download Extras" drop down. It will find the package. Install it.

              I have installed vapor and ran the package however I get an error:

              Error extracting package, could not pack transport: localhost:8181-140218.1135.13-2.2.11-pl Vapor execution completed without exception in 15.7796s

              Checking the vapor error logs in : modx\core\cache\logs I see the following:

              [2014-02-18 10:57:56] (INFO @ /modx/vapor/vapor.php) core_path=C:\wamp\www\modx\core/
              [2014-02-18 10:57:56] (INFO @ /modx/vapor/vapor.php) assets_path=C:\wamp\www\modx\assets/
              [2014-02-18 10:57:56] (INFO @ /modx/vapor/vapor.php) manager_path=C:\wamp\www\modx\manager/
              [2014-02-18 10:57:56] (INFO @ /modx/vapor/vapor.php) base_path=C:\wamp\www\modx/
              [2014-02-18 10:57:56] (INFO @ /modx/vapor/vapor.php) Created new transport package with signature: localhost:8181-140218.1057.56-2.2.11-pl
              [2014-02-18 10:57:56] (INFO @ /modx/vapor/vapor.php) Packaging C:/wamp/www/modx/core/components
              [2014-02-18 10:57:56] (ERROR @ /modx/vapor/vapor.php) Source file C:/wamp/www/modx/core/components is missing or C:/wamp/www/modx/core/packages/localhost:8181-140218.1057.56-2.2.11-pl/xPDOFileVehicle/56901effab48a5eecf3c0a4a1ac754fa/ is not writable
              [2014-02-18 10:57:56] (ERROR @ /modx/vapor/vapor.php) Could not store vehicle to file C:/wamp/www/modx/core/packages/localhost:8181-140218.1057.56-2.2.11-pl/xPDOFileVehicle/56901effab48a5eecf3c0a4a1ac754fa.vehicle
              [2014-02-18 10:57:56] (INFO @ /modx/vapor/vapor.php) Packaging C:/wamp/www/modx/assets
              [2014-02-18 10:57:56] (ERROR @ /modx/vapor/vapor.php) Source file C:/wamp/www/modx/assets is missing or C:/wamp/www/modx/core/packages/localhost:8181-140218.1057.56-2.2.11-pl/xPDOFileVehicle/7da711bc4cdf6882553d79970b89321f/ is not writable
              [2014-02-18 10:57:56] (ERROR @ /modx/vapor/vapor.php) Could not store vehicle to file C:/wamp/www/modx/core/packages/localhost:8181-140218.1057.56-2.2.11-pl/xPDOFileVehicle/7da711bc4cdf6882553d79970b89321f.vehicle

              etc etc


              I checked the folder permissions to see if the directories are write-able... they are not. When I try to change the security permissions I get a further error message: Error Applying Security - Access is denied.

              I don't gave issues granting permissions to any other sites/directories within my local environment so is this something specific to MODX?