We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36886
    • 5 Posts
    For the last 2 years I have had a modx evo site (version 1.0.8) installed with one.com (I have a few modx sites with them, these all work fine still).
    This weekend I tried logging into the manager. I enter my username, password, hit login and the page just refreshes with the empty login form.
    I thought maybe I got the wrong password, so tried a different one and then I did get the popup of wrong password, try again etc.
    I tried the reset password email, I receive the emails and click on the link in it, and get redirected back to the blank login page.

    I logged into my control panel at one.com and into phpMyAdmin. Looking at the manager event log table, it shows that my login attempt did go through, but I still cant access the manager.
    I did some searching on these forums and came to the conclusion it was linked with cache or sessions.
    I tried clearing out my browsers cookies and cache, nothing.
    I have tried different browsers, nothing.
    I have tried different computers, nothing.
    I have tried from different location (ie different ip addresses), nothing.

    I then figured I would upgrade to version 1.0.12, since I meant to do that for a while, and read that would clear out the old sessions.
    All the files upload fine, I run through the installation fine, I check I accept the license etc, then on the last page get this error:

    Setup will now attempt to setup the database:

    Creating connection to the database: Database connection failed!

    Please check the database login details and try again.

    I thought this was strange as it used the database info from the current site, and the site is working fine, all content etc showing perfectly.
    So I went for the advanced upgrade, entered the database info etc, clicked the test buttons, did the database name and table etc, all the test went fine. Clicked next, install all the extras, click next and get the list of in pre-install validation, all say OK. Then at the bottom again the same error message:

    Creating connection to the database: Database connection failed!

    Please check the database login details and try again.

    Database could not be selected!
    Please check the database permissions for the specified user and try again.

    and I can't go any further.
    I gave up all hope and tried to just make a fresh install of modx in a folder with a different table prefix (I only get one mysql database), trying the complete new install and I got the same error message.
    I contacted the support at one.com, they just directed me to a forum post about clearing out sessions in revo and are not any help.
    I have tried everything I could find and just don't know what else to try.
    Any help, or points in the right direction would be fabulous, thank you.
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Try repairing the user tables in the database. Sometimes a corrupted table will cause this.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 36886
        • 5 Posts
        Thank you for the suggestion
        I did repair on the below tables and it says they are all ok now but I still can't access the manager.

        modx_manager_users
        modx_membergroup_access
        modx_membergroup_names
        modx_user_attributes
        modx_user_messages
        modx_user_roles
        modx_user_settings
          • 36886
          • 5 Posts
          Well after pestering the webhost some more, and going over everything I had tried they put me in touch with a tech guy who actually listened.
          Unfortunately I don't know what exactly they did, but I can now log into the site.

          They did say it was to do with the sessions of the site, for anyone experiencing the problem.


          I also noticed, I have a php script (in a snippet) that sets the copyright date, it was on 2013 when I could not long in, and now it is fixed it updated to 2014. Handy diagnoses tool?
            • 13428 ☆ A M B ☆
            • 1,031 Posts
            If the session folder is corrupted, the login symptoms could occur. The wrong copyright points a bit in a caching issue (whole installation was not writeable or accidentally cached in my opinion). But it is away and if your provider does not tell you what happened, you will never know the reason for the issue.