On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Description of Problem:
    Just upgraded my work's web site to Evo 1.0.12 and it's been a bit rocky. First off I discovered that the feature that allows you to navigate to a page via document ID in the url no longer works, but corrected that according to the discussion found here: http://forums.modx.com/thread/88918/www-domain-com-docid (Thanks Jako!)

    Now I've noticed that when editing a page via the QuickManager+ plugin, toggling TinyMCE off by setting Editor to Use to None removes the [*content*] text area entirely. While editing the page in the manager proper, I get the lovely CodeMirror editor. But no love through QuickManager+.

    Anyone else out there run into this issue? Below are some technical details that I'm guessing will help.

    Steps to Reproduce:

    1. Log in to manager
    2. View site via Preview button in manager
    3. Click Edit button in QuickManager+ toolbar
    4. Set Editor to Use to None

    Expected Outcome:
    [*content*] text area should still be there, either with CodeMirror or just as plain text

    MODX Version: 1.0.12 but uses Document parser from GitHub Commit https://github.com/modxcms/evolution/commit/63856c833e1ba9d02cac1f6fa68bac20144f0b25
    PHP Version: 5.3.5
    Database (MySQL) Version: 5.1.54
    Additional Server Info: LAMP
    QuickManager+ Versrion and Config: 1.5.6 (added line breaks for readability)
    &jqpath=Path to jQuery;text;assets/js/jquery.min.js
    &loadmanagerjq=Load jQuery in manager;list;true,false;false
    &loadfrontendjq=Load jQuery in front-end;list;true,false;false
    &noconflictjq=jQuery noConflict mode in front-end;list;true,false;false
    &loadtb=Load modal box in front-end;list;true,false;true
    &tbwidth=Modal box window width;text;80%
    &tbheight=Modal box window height;text;90%
    &hidefields=Hide document fields from front-end editors;text;parent
    &hidetabs=Hide document tabs from front-end editors;text;
    &hidesections=Hide document sections from front-end editors;text;
    &addbutton=Show add document here button;list;true,false;true
    &tpltype=New document template type;list;parent,id,selected;parent
    &tplid=New document template id;int;3
    &custombutton=Custom buttons;textarea;
    &managerbutton=Show go to manager button;list;true,false;true
    &logout=Logout to;list;manager,front-end;manager
    &disabled=Plugin disabled on documents;text;
    &autohide=Autohide toolbar;list;true,false;false
    &editbuttons=Inline edit buttons;list;true,false;false
    &editbclass=Edit button CSS class;text;qm-edit
    &newbuttons=Inline new resource buttons;list;true,false;false
    &newbclass=New resource button CSS class;text;qm-new
    &tvbuttons=Inline template variable buttons;list;true,false;false
    &tvbclass=Template variable button CSS class;text;qm-tv

    CodeMirror Versrion and Config: 1.2b (added line breaks for readability)
    &indentUnit=Indent unit;int;4
    &tabSize=The width of a tab character;int;4

    This question has been answered by juliolopez78. See the first response.

    [ed. note: juliolopez78 last edited this post 7 years, 8 months ago.]
    • discuss.answer
      Thanks again to Jako for offering help with this solution. I'd come up with something that relied on jQuery, but have now changed my tune to not using it as it may not be there in all instances/installs.

      So I opted for using the simpler solution posted here: http://stackoverflow.com/questions/799981/document-ready-equivalent-without-jquery#answer-11810957 (Thanks again Jako). I think that for my purposes this will work, but with regard to a final, production- and release-ready solution, the MODX Evo team will probably want to consider something more robust.

      By the way, I'm curious to know if anyone else has noticed this issue, or if I'm experiencing it due to my config and plugins.

      	var tId = setInterval( function() { if (document.readyState == "complete") onComplete() }, 11 );
      	function onComplete(){