Description of Problem: My Website was up and running for the past 6 months with no issues, suddenly, out of nowhere, whenever we try to login to the Manager it says "That account could not be located. Check the username and re-type the password to try again."
This happens for all accounts, all exists in the DB and active.
Steps to Reproduce: Sadly, this seems to be random.
Debugging steps so far & useful information:
- There's no errors in the logs (Server and modx)
- I re-installed modx, fresh install,restore DB, it worked, 1 day later same issue again.
- I had a DB & Files backup when it worked, when i overwrite the files only or restore the DB only, it do not work, I have to overwrite the manager files & restore the DB.
- When restoring the DB, it seems that there's a lot of records were missing!!
- I took an image of the broken files and DB, uploaded it to another host, fixed it as stated above, and it's working with no issue for a month now!
- There's no activity on the server that might be accessing the DB
- When i do the fix again (Overwrite the manager files from the latest working backup & Restoring the DB) sometimes it work for 2 hours, sometimes for 2 days!
If - and that what i'm suspecting - this is a server issue, what would be causing it! seems a bit crazy to me. Would appreciate any help though.
- MODX Version: 2.2.11
- PHP Version: PHP Version 5.3.3
- Database (MySQL, SQL Server, etc) Version: MySQL version 5.0.95
- Additional Server Info: OS: CentOS Linux 5.9 - Kernel and CPU: Linux 2.6.18-348.3.1.el5 on x86_64 - Apache version 2.2.3
- Installed MODX Add-ons: N/A
- Error Log Contents: (attach as file if it’s too large) Empty!
Thanks,
Ali