On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I have the following issue: I created the ditto call below, which I call in a uncached page. (The issue is identical if I do the call uncached.) When I set display to "all", I get 6 items. Wen I set it to three, it should paginate. Problem is, that Ditto finds only one result page instead of two. I tried over hours to resolve the issue. I read a bunch of forum posts here, but i did not find the issue, yet. I tried also to set display to all and total to 3: same result.

    [[Ditto? &id=`wp` &parents=`24` &display=`3` &tpl=`BlogHomeRow` &extenders=`summary,dateFilter,tagging` &dateSource=`pub_date` &sortBy=`pub_date` &removeChunk=`Comments` &paginate=`1` &tagData=`documentTags` &tagDelimiter=`, ` &paginateAlwaysShowLinks=`1` &noResults=`This blog does not contain any articles.` &debug=`1` &phx=`0`]]
    
    (previosus:[+wp_previous+]) (current:[+wp_currentPage+]) (pages:[+wp_pages+]) (next:[+wp_next+])
    (totalPages:[+wp_totalPages+]) (pages:[+wp_pages+])


    P.S.: This is the output the last line generates:

    (previosus:) (current:1) (pages:1) (next:) (totalPages:1) (pages:1)

    I appreciate any help. I spent already too much time on this...

    Thank you.


    [additional info:]
    Even though I use &paginateAlwaysShowLinks the previous and next buttons are not showing [ed. note: holgermeier last edited this post 5 years, 6 months ago.]
    • Is the PHx plugin in use? It's always a prime suspect in this sort of case. If it is, then versions may be relevant (of MODX and of PHx). What versions are you using? Certainly in the past it has been a hard and fast rule that you'd have to have the page uncached and the Ditto call cached for pagination to work. That may have changed with the latest version of PHx.

      Why do you have &phx=`0` in the call? Has it always been there, or is it part of an attempt to fix the problem?

      Has the &debug=`1` produced any output?

      :) KP