Subscribe: RSS
  • Attempting to use the latest version of mxCalendar (1.1.10) but no rich text editor appears in either the Description or Content (this is a new field it seems) fields of a calendar item.

    Does it require TinyMCE?
    • So, I am not sure why it is having an issue, and I don't like messing with the source code, but to get the ExtJS htmleditor to show up, I have to comment out a few lines of code in the assets/components/mxcalendars/js/mgr/widgets/mxcalendars.grid.js:

      Lines 581 and 605, I have to hard code it to
      xtype:'htmleditor'
      and comment out the check statement.

      then, I have to comment out the tinymce var check at line 824.

      I use ckEditor (soon to implement redactor) on the site.

      And even when I installed TinyMCE to try to get things to work (even set which_editor to TinyMCE to see), the RTE would not show up.

      • Sorry that was a bug and didn't get the bug released to fix. Coming in the release very soon. Apologies.
          Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
          Visit CharlesMx.com for latest news and status updates.
        • For anyone else who stumbles across this post before it's fixed in a release, I managed to find an easy way to fix it. (Although I don't use CKEditor, I use TinyMCE).

          In System Settings, search for mxcalendars.use_richtext then right click and hit Update Setting. For Namespace, select mxcalendars (with an s, this is the important part) and then change the value to Yes and save.

          I have repeated this on several installs I was having this problem on and it has worked for me each time.
          • Just commenting here because this is still an issue and it took me a long time to find what the problem was. So if you're having problems using TinyMCE and MxCalendars this may be a good place to start. Thank you Shonna.
              Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk