On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I have got a Articles setup with quip for comments. In the articles overview I've got a link to the comments anchor and a counter next to it with QuipCount. In my ArticleRowTpl that line is as follows:
    [[+comments_enabled:is=`1`:then=`| <a href="[[~[[+id]]]]#comments" class="comments">[[%articles.comments]] ([[!QuipCount? &thread=`article-b[[+parent]]-[[+id]]`]])</a>`]]


    So I've got the ! in the snippet call to make sure it is called uncached, but still it will display an inaccurate count. It says there are 0 comments, but when I view the article there are 2 for example. When I go back to the article overview page (and refresh) it still says there are no comments.

    Finally when I clear cache the number of comments displayed is correct.

    Anyone knows what's wrong? Thanks in advance.
    • There must be other people having this problem too right? I found some on the forums but no solution to be found...
      • In your ressource-settings disable "cache active"
        • Thank you for answering my question. Although it has been a long time ago I am still dealing with this issue. Problem is: I am using articles which has some kind of custom manager layout which does not display the caching checkbox. Anyway how to solve this?

          Thanks in advance.