We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 46060
    • 27 Posts
    when I save a resource group in 2.2.10, the 'Please Wait ... Saving' modal dialogue box pops up, the animated loading bar loops, but it never disappears on its own.

    when I reload the page, it seems as though the proper group was created, and if I have 'create parallel user group' selected, it also seems to create that properly.

    any ideas on where to begin looking?

    I've reinstalled MODx and it's still the same.


    thanks,
    -Dustin

    This question has been answered by blankha. See the first response.

    [ed. note: blankha last edited this post 12 years, 8 months ago.]
      • 3749
      • 24,544 Posts
      Is there anything in the MODX error log (Reports > Error Log)?

      Are there any plugins that might be firing when a group is created?
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • discuss.answer
        • 46060
        • 27 Posts
        Hi Bob,

        Quote from: BobRay at Jan 08, 2014, 05:08 PM
        Is there anything in the MODX error log (Reports > Error Log)?

        nope. nothing from creating a resource group.


        Are there any plugins that might be firing when a group is created?

        this is what I've got installed:

        gallery
        inheritresourcegroup
        login
        versionx
        wayfinder


        I thought the problem began sometime after I installed 'inheritresourcegroup' so I uninstalled it, and then when that didn't help I also uninstalled gallery, since that was the last most recent one, but that didn't fix the problem either.


        I think the answer is 'yes,' but might a plugin affect MODx even after a successful uninstallation? do you think this is likely?


        where else could I look?
          • 3749
          • 24,544 Posts
          Yes, I've definitely had plugins hang around after uninstalling their package. The often happens if you had a previous version of the package installed, but I think sometimes it happens without that. It depends on how the package is written.

          InheritResourceGroup would be by far the most likely culprit.

          Look in the modx_site_plugins table in the DB to see which ones are still there and whether they're disabled.

          If you make any changes there, delete all files in the core/cache directory (or install and run CacheClear).

          Another possibility is a mismatch between the various date/timezone settings (MODX, PHP, MySQL).

          You could also have one or more invalid modResourceGroupResource objects, though I think that's less likely.

          SiteCheck will check both the date/timezone and all the modResourceGroupResource objects for you (along with a lot of other things). http://bobsguides.com/sitecheck-tutorial.html
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting