We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 10386
    • 42 Posts
    HI, I have just installed the last version of MODX, I was last on evolution, I am rebuilding my website from scratch, so far so good, except for this tenacious error popping up every time I try to access my resources, what should I look into? Is it the server configuration, or some file right?
    Internal Server Error
    
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    
    Please contact the server administrator, www.123-support.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    
    More information about this error may be available in the server error log.
    Apache Server at ventoline.co.uk Port 80
    
    
    [ed. note: gaelle last edited this post 12 years, 8 months ago.]
      • 10386
      • 42 Posts
      this seemed to be caused by the scripts timing out due to a lack of PHP memory, where could i modify the settings?

      According to the server logs this error occurs because one of your scripts/plugins requires more resources (php memory).
      
      From the additional checks we've made and since there is no single script that is causing these errors, we believe the scripts are timing out due to a lack of PHP memory. If the allowed maximum PHP memory for shared-hosting packages (128 MB) is reached, the script that was running at that time will time-out, thus returning the attached errors.
      
      This limit cannot be increased on our packages, regardless of the hosting plan you have, as such the only recommendation we can give is to try and optimise the installation, such as removing any plugins or 3rd party scripts that might be consuming too much memory.
      
      As this is a shared hosting package cache plugins may have a negative impact over your website performance.
      
      Usually these plugins require a large amount of memory in order to store data into the cache.
      
      As these plugins consumes most of your hosting package resources the website scripts will time out (never complete due to low memory), this resulting to Internal Server Errors.
      In this case we would recommend disabling all plugins and enabling them one at a time, testing which one might cause this issue.
      
      Below you can see only few error logs that were thrown when your website had an Internal Server Error:
      
      2014-01-14T19:17:42+00:00 linweb20 httpd[2790]: [error]  SystemException in API_Linux.cpp:172: setuid() failed: Resource temporarily unavailable, referer: http://www.ventoline.co.uk/manager/index.php?a=23&id=4
      2014-01-14T19:17:42+00:00 linweb20 httpd[2790]: [error]  Premature end of script headers: index.php, referer: http://www.ventoline.co.uk/manager/index.php?a=23&id=4
      [ed. note: gaelle last edited this post 12 years, 8 months ago.]
        • 3749
        • 24,544 Posts
        It really sounds like you need a more MODX-friendly host. MODX is running fine on many inexpensive, shared hosts. Your host doesn't sound very accommodating or helpful.

        http://bobsguides.com/modx-friendly-hosts.html
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 36582
          • 463 Posts
          You're going to face an uphill battle with that particular host and Revo. Save yourself the hassle and get some friendly hosting.
            Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
            • 10386
            • 42 Posts
            Thank you for this, I will look into this alas, I have another 6 months hosting to go. Silly question, how did you find out which host I am using- Im curious - ?
            In my researches stumbled in this ad from my host 123-reg: https://www.123-reg.co.uk/web-hosting/free-123-apps/modx.shtml I dont use this particular product, maybe should I update my plan, or use their particular set up? Or would you think there still would be issues; could you be more specific whith regards to what makes a host MODx friendly?
              • 28042 ☆ A M B ☆
              • 24,524 Posts
              how did you find out which host I am using
              For one thing, knowing exactly what host you are using isn't necessary to know that any hosting support that returns a response like that means trouble. On the other hand, your first post tells us what hosting you're using.

              Please contact the server administrator, www.123-support.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.
                Studying MODX in the desert - http://sottwell.com
                Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                Join the Slack Community - http://modx.org
                • 3749
                • 24,544 Posts
                Quote from: gaelle at Jan 16, 2014, 05:39 AM
                Could you be more specific with regards to what makes a host MODx friendly?

                Mainly, on a MODX-friendly host, you install MODX and it just works. I have several fairly complex sites on various MODX-friendly hosts and have never had a MODX-related problem with them. I should mention that the folks at SkyToaster (http://bit.ly/164aT9l) are very active on the MODX Forums. I can promise you that in the unlikely event that your problem occurred there, you would have gotten a very different response from them and the problem would have been fixed in short order with their help.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 10386
                  • 42 Posts
                  Sorry i must have spent too long in front of a screen.
                  Quote from: sottwell at Jan 16, 2014, 11:57 AM
                  how did you find out which host I am using
                  For one thing, knowing exactly what host you are using isn't necessary to know that any hosting support that returns a response like that means trouble. On the other hand, your first post tells us what hosting you're using.

                  Please contact the server administrator, www.123-support.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.
                    • 10386
                    • 42 Posts
                    Thank I ll try bringing up the issue again, and pointing that they use MODx as a selling point, see if they are being more helpful, if not, i try to move host.
                      • 10386
                      • 42 Posts
                      OK,
                      So I am finally - 5 months in- coming around to move host, and checked the list kindly presented to find out they are all in US! Any
                      host remarkably good with MODx in Europe, specifically UK -doesnt have to be-?