Ok, this is odd to me. I have a client that I created a site for a while back and he can't seem to save content changes at his computers at work. He tells me that the saving icon just continuously spins.
Now I have no prob at all on my computer in my office or at my home. I use safari to make my changes on my Mac in OS X 10.6.8. He has used multiple versions at the office but it does work on his home computer.
I guess my question would be, do you think the wireless connection might have an issue with this. I mean, he does have multiple people at the office working off wireless. Would a slow connection cause this? He is logging on as the admin so security shouldn't be an issue. I am just really at a loss as to what would be causing this. Any help or ideas would be appreciated. Thank you.
Wireless sounds unlikly or he would be experiencing problems with all websites/internet browsing. What browser is he using when the problem occurs? Any error logs? I also remember a few years ago I experienced problems with the manager when a corporate ISP did something to a clients proxy server/firewall. Can't remember what the issue was but might be a possibility.
This was his reply to me:
Personally, I use Mac OS 10.9 (Mavericks) and have had the same issue using Safari, Chrome, and Firefox. I also have a Parallels VM, which uses Windows 7 Ultimate, and I have the same issue using Internet Explorer and Chrome (I’ve not tried Firefox on their).
I’ve also tried using several computers in our office that run a variety of OS (Windows XP, Windows 7), using the same variety of web browsers.
Since my previous email, I have had limited success (once) in updating our website from our offices. I was using Safari on my Mac at the time. I was able to save one edit that session, and then we were back to the issue of being stuck at the “Saving” screen with no changes saved.
When I was experiencing this issue on Monday we happened to have our server IT guys in the office. I asked them if they had any idea what could be the issue. They are seem as confused as I am. We’ve looked into service providers (Time Warner), but I have Time Warner at home and I can make edits at home.
Does sound very odd. Anything in the server or MODX error logs?
Wow, yes I just checked it, there are a lot of them, I don't even know where to begin now. here are the first few:
[2013-07-22 11:16:45] (ERROR @ /connectors/system/index.php) Error caching lexicon topic lexicon/en/core/default
[2013-07-22 11:18:17] (ERROR @ /connectors/lang.js.php) Error caching lexicon topic lexicon/en/core/resource
[2013-07-23 08:54:14] (ERROR @ /connectors/system/phpthumb.php) phpThumb was unable to generate a thumbnail for: /nfs/c08/h01/mnt/171806/domains/conseal.com/html/core/cache/phpthumb/phpThumb_cache_conseal.com.s171806.gridserver.com_src618e409af5cd560bab19c92b0c8de8c9_paradf896d45f319fa323d889e84ccb98c5_dat1365523888.jpeg
[2013-07-23 08:54:14] (ERROR @ /connectors/system/phpthumb.php) Error outputting thumbnail:
OutputThumbnail() failed because !is_resource($this->gdimg_output) in file "phpthumb.class.php" on line 557
[2013-07-23 12:34:47] (ERROR @ /connectors/browser/directory.php) Error caching lexicon topic lexicon/en/core/source
[2013-08-09 06:51:52] (ERROR @ /connectors/lang.js.php) Error caching lexicon topic lexicon/en/core/resource
[2013-08-12 12:42:06] (ERROR @ /connectors/layout/modx.config.js.php) Error caching lexicon topic lexicon/en/core/resource
[2013-08-21 12:45:16] (ERROR @ /index.php) Could not cache resource 17
[2013-08-21 12:45:16] (ERROR @ /index.php) Could not cache resource 17
[2013-08-22 11:37:37] (ERROR @ /manager/index.php) Error 23000 executing statement:
INSERT INTO `db171806register_messages` (`topic`, `id`, `created`, `valid`, `accesses`, `expires`, `payload`, `kill`) VALUES (1, 'c4ca4238a0b923820dcc509a6f75849b', '2013-08-22 11:37:28', '2013-08-22 11:37:28', 0, 1377197008, 'if (time() > 1377197008) return null;\nreturn 1;\n', 0)
Array
(
[0] => 23000
[1] => 1062
[2] => Duplicate entry '1-c4ca4238a0b923820dcc509a6f75849b' for key 'PRIMARY'
)
what does this mean? This must be the one thats giving him problems for now since it is the latest error.
[2013-12-30 12:41:06] (ERROR @ /connectors/resource/index.php) Resource URI technical-resources/application-specifications/76/cs-50-solvent-based-liquid-butyl-primer.html already exists for resource id = 87; skipping duplicate resource URI for resource id = 88
It means there is a resource that already has the same alias/URI (id 87) which is why he can't save a new one (id 88). Under the friendy URL settings there is this: 'allow_duplicate_alias' that stops duplicate aliases.
I would log in and check what resources he has created. He might not have published them which is why he thinks nothing is happening when he tries to create it again.
If there is nothing in the resource tree then check the database.
[ed. note: davidpede last edited this post 12 years, 9 months ago.]
It's quite possible to have resources that don't show in the tree. This would find and fix them (along with many other problems):
http://bobsguides.com/sitecheck-tutorial.html