One of our sites occasionally has a problem where it seems to build the file cache only partially or in correctly.. it's happened twice within the last 15 days. I'm trying to determine a cause.. but I'm not having any luck.
We're using version 2.2.10-pl on centos 6, php 5.3.3, apache 2.2.15, mysql 5.1.69.
The symptoms have varied slightly.. the first time it happened, images in articles didn't display. Clearing the cache in the manager fixed it. Second time, the styling for the home page went way and content .. again clearing the cache fixed it.
In the web logs, I can see where the site.css was being loaded by clients... then clients stopped requesting it.. and kept hitting the home page over and over (because they couldn't make it to any other page in the site). .. I can also see that no one was in the manager at the time (last person was out 3 hours prior to the problem starting).
There are no errors in the weblogs, and no errors (or even recent messages) in the site error.log. The only thing of a little interested is we were getting indexed by msnbot at the time.. but that happens about every 30 minutes (along with some others), so it's probably unrelated to the problem.
Is there some sort of debugging that it would be worth turning on that would show if there was a problem when the site rebuilds the cache?
Thanks