We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36551
    • 416 Posts

    I've recently installed modx on shared hosting (Blue Host) and have no thumbnails in the modx manager. Images are fine on front-end.

    The modx error log has a series of these errors:

    [2013-12-17 17:06:03] (ERROR @ /~xxxxxxx/connectors/system/phpthumb.php) phpThumb was unable to generate a thumbnail for: /home8/xxxxxxx/public_html/core/cache/phpthumb/phpThumb_cache_xx.xxx.xxx.xxx_src9e10eb27fa6779582213b946b33344bd_par02a1b054e8467fb1e234c8a8fd8d10d2_dat1387047367.png
    [2013-12-17 17:06:03] (ERROR @ /~xxxxxxx/connectors/system/phpthumb.php) Error outputting thumbnail:
    OutputThumbnail() failed because !is_resource($this->gdimg_output) in file "phpthumb.class.php" on line 557
    


    Modx 2.2.10
    PHP Version 5.2.17 (when modx was installed it was 5.4, we changed it today)

    Immediately after installing modx I installed a transport package (made with packman) of bunch of addons which include pthumb and xfpc. I've done this on numerous sites with no problems.

    Since xfpc is a cache related addon I tried to uninstall it but am unable to do so. Console says it has been removed but it is still in the grid. Here's what it says:

    Finding package with signature: xfpc-2.1.0-pl1
    Could not open file for reading: xfpc-2.1.0-pl1.transport.zip?revolution_version=Revolution-2.2.10-pl
    MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
    Could not transfer package xfpc-2.1.0-pl1.transport.zip to /home8/xxxxxxx/public_html/core/packages/.
    Package found. Preparing to uninstall.
    Could not open file for reading: xfpc-2.1.0-pl1.transport.zip?revolution_version=Revolution-2.2.10-pl
    MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
    Could not transfer package xfpc-2.1.0-pl1.transport.zip to /home8/xxxxxxx/public_html/core/packages/.
    Package successfully uninstalled with signature: xfpc-2.1.0-pl1


    I've confirmed that cURL is enabled. I can successfully download additional addons.

    I've also turned off compressjs and compress_css

    I've manually cleared the cache folders after each one of these changes to now effect.

    I'm out of ideas. Any suggestions?
      • 38290
      • 712 Posts
      To confirm, you went from php 5.4 back to 5.2 today?
        jpdevries
        • 1343 ☆ A M B ☆
        • 2,213 Posts
        Quote from: dinocorn at Dec 18, 2013, 01:06 PM
        To confirm, you went from php 5.4 back to 5.2 today?

        I'm guessing/hoping he means PHP 5.3, as using php 5.2 today is a little crazy. The last security update was Jan 6, 2011. I'm amazed any host would still be offering it considering it's almost three years old, the amount of unpatched security holes...

        Getting back to the topic at hand, considering that a growing number of extras (ex: Resizer part of pThumb) require the use of php 5.3 or higher, the use of an older PHP version alone is likely part of the problem.

        If you could please confirm the version of PHP in use, and provide the phpinfo output for the server we can go from there.
          Patrick | Server Wrangler
          About Me: Website | Tweets |  MODX Hosting
          • 36551
          • 416 Posts
          Yes, it was at 5.4.22. The support tech suggested we try going back a version, but they don't have 5.3 available.

          Based on your comments, it's clear I should go back to 5.4.22. So I've just done that.

          It seems to have no effect on either of these problems.

          No thumbnails and unable to uninstall xfpc.

          Here's the phpinfo

          PHP Version 5.4.22
          
          System 	Linux box705.bluehost.com 3.4.72-20131204.1.bh6.x86_64 #1 SMP Wed Dec 4 18:02:42 EST 2013 x86_64
          Build Date 	Dec 9 2013 00:23:07
          Server API 	CGI/FastCGI
          Virtual Directory Support 	disabled
          Configuration File (php.ini) Path 	/usr/php/54/etc
          Loaded Configuration File 	/usr/php/54/etc/php.ini
          Scan this dir for additional .ini files 	/usr/php/54/etc/php.d
          Additional .ini files parsed 	(none)
          PHP API 	20100412
          PHP Extension 	20100525
          Zend Extension 	220100525
          Zend Extension Build 	API220100525,NTS
          PHP Extension Build 	API20100525,NTS
          Debug Build 	no
          Thread Safety 	disabled
          Zend Signal Handling 	disabled
          Zend Memory Manager 	enabled
          Zend Multibyte Support 	provided by mbstring
          IPv6 Support 	enabled
          DTrace Support 	disabled
          Registered PHP Streams	https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
          Registered Stream Socket Transports	tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
          Registered Stream Filters	zlib.*, bzip2.*, convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk
            • 38290
            • 712 Posts
            Can you tell if ImageMagic or GD Library are installed?
              jpdevries
              • 36551
              • 416 Posts
              The tech support guy said they are installed and I see this in the php.ini in the root folder

              zend_loader.disable_licensing=0
              extension=imagick.so
              zend_extension=/usr/php/54/usr/lib64/php/modules/ZendGuardLoader.so
              
                • 36551
                • 416 Posts
                Anyone have any other ideas?

                Do I need to start over with this installation? On a different server/host?

                Thanks.
                  • 53432
                  • 46 Posts
                  I've had many challenges getting phpthumb to work, so, i'll take a shot at this:

                  First, make sure this folder is writable by PHP:
                  /home8/xxxxxxx/public_html/core/cache/phpthumb

                  Second, take a look at the value you are passing into phpthumb. It should be a path, not a URL.

                  Third, run phpinfo() and verify whether PHP is actually loading your php.ini file. On some servers, that ini file is ignored. Also there can be a delay between editing the INI file and PHP actually becoming aware of the edits.

                  Hope this helps.
                    • 36551
                    • 416 Posts
                    The core/cache/phpthumb folder permissions are set to 0755

                    I've not set any value for phpthumb. It's installed in the grid, but I've done nothing with it so far.

                    When I run phpinfo I get the usual report, same as when I check system info from within the modx manager.


                      • 1343 ☆ A M B ☆
                      • 2,213 Posts
                      Do you use the actual domain name or a temporary address with the tilde (~)? Also what if any information do you get when viewing the net data while attempting to load the file manager?

                      Lastly have you checked the Error Log in cPanel?
                        Patrick | Server Wrangler
                        About Me: Website | Tweets |  MODX Hosting