We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 16942
    • 33 Posts
    In the Manager, I've noticed since Revo 2.2.10-pl that if you try to manage any component, it's returning "Could not load controller request handler". The error logs aren't very helpful. For example, for the 'redirector' component, it just says:
    [2013-12-07 02:57:57] (ERROR @ /manager/index.php) Could not load class: redirectorControllerRequest from redirector.request.redirectorcontrollerrequest.

    As the components themselves are working, I'm guessing it's a fault with the Manager. Does anyone have an ideas as to the cause?
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Was this an upgrade?

      Can you give a specific example of a component, and what exactly you did to get the error?
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 16942
        • 33 Posts
        Yes, I've got spittingred's Redirector installed. As a component, its public-facing functionality is fine.

        However in Manager, if I mouseover Components and choose Redirector, I get "Could not load controller request handler."

        Also 'Cron Manager' does the same thing

        This worked prior to 2.2.10-pl but that version seems to have broken a lot of things.
          • 3749
          • 24,544 Posts
          You might open it up with Chrome Dev. Tools active (Ctrl-shift-i) and take a look at the Network tab to see there are any clues to what's going wrong.

          You might also put a line in the index.php action file for a component that writes the path it's using to "include" the controller request handler to the MODX error log:

          $modx->log(LOG_LEVEL_ERROR, 'Controller Request Path: ' . $path;


          Put it just above any "include" statements.

            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            Installed them both on my localhost 2.2.10 installation and they work just fine. Have you tried uninstalling and removing them, then installing them again?
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 16942
              • 33 Posts
              OK so some interesting observations.

              No errors logged when adding that line. No entry for the Controller Request Path. No failed responses when looking at the network tab in firebug.

              Attempting to uninstall Cron Manager gave me the error:
              Console running...
              Grabbing package to remove...
              Problem instantiating object from vehicle
              Problem instantiating object from vehicle
              Recoverable error: Object of class xPDOObjectVehicle could not be converted to string
              Error uninstalling package with signature: Object
              Error removing package with signature: [[+signature]]

              Attempting to uninstall redirector, seemed not to do anything - by which I mean, you click Uninstall, you then choose Uninstall from the three radio buttons, then you click Uninstall and the console window just says "Console running..." but seems to stall

              Attempted a brute-force uninstallation by deleting all redirector directories and zips in /core/packages but strangely it still appears in the package manager even after clearing the site cache.
                • 16942
                • 33 Posts
                Some brain surgery on the database to remove 'redirector' references followed by a re-installation of the component seems to have turned that one good. Reluctant to do the same with Cron Manager because, whilst doing a global search across all tables in the db for 'redirector', is highly likely to return matches only relating to the package, searching for 'cron' could inadvertently sweep up something unrelated to the package but vital to the working of modx.