New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Hi all,

    When I install discuss I get the following error:

    Could not load class: disParticipant from mysql.disparticipant.


    Everything works fine apart from /forums/thread/new_replies_to_posts (unread replies since last visit)

    The following errors comwes up
    [2013-11-19 07:31:53] (ERROR @ /index.php) Error 42S02 executing statement: Array ( [0] => 42S02 [1] => 1146 [2] => Table 'coinzi.modx_discuss_thread_participants' doesn't exist )


    I have tried to re-install, but keep getting the same error.

    Appreciate any help smiley

    • I have the exact same error when trying to install/reinstall.

      My forum top level entry page (/forum) seems to load fine, but when I click on a board it displays my homepage (despite the URL having /forum/board/...) and I have the exact same error in my Error Log.

      I realize I can recreate the MySQL table structure as a workaround (as I've read in other discussions re: similar issues), but I don't know what other impact this error may have so I'd prefer a cleaner solution.
      • I'm having the exact same issue. It happens both when I install the latest, empty release of ModX and also when I try and upgrade a previously working version.

        Has anyone got any fixes / workarounds?
        • I've figured it out! smiley

          It looks like there was just 1 line of code missing from the package management release. If you download the package manually from GitHub, then place it in the packages folder, you can then tell package management to search for local packages! It's then the same as any other package from there. Here's the GitHub link:

          https://github.com/modxcms/Discuss/blob/develop/_packages/discuss-1.2-pl.transport.zip
          • Hey,

            I've tried this but I still get this error when I install Discuss =(

            Any solution?!

            Thanks!
            • Is it just an error during install or does it cause problems after installation?
              • Ребята! Пишу одновременно на двух языках, чтобы не заморачивались ни те, ни другие: не переживайте, не страшно, что это класс был утерян!!! Благодарите Бога, что сам форум не утеряли!
                Мой "Дискусс" сейчас работает, не смотря на то, что я его снес, он криво встал, снова снес вместе с этим классом. При переустановке не это страшно: страшно, что форум перестает переадрессовываться! И если вы сами устанавливали "Дискусс" на сервак, то помните, что после установки надо настроить Логин, а потом произвести подстройки "Дискусс" на вкладке "Настройки системы" МодХ.

                Перевожу:

                People! I am writing in two languages, so as not to bother as russian as english men: Don't worry, no big deal, what it's class was lost !!! You most thanks the God that the your forums itself is not lost!
                My "Discuss" is working, despite the fact that I had knocked down, he wryly rose, again demolished along with this class. When reinstalling no it terrible: terrible, that the forum is no longer diverted to itself pages! And if you do set a "Discuss" on a server, you are remember that after installation, you have to configure the Login, and then make an adjustment "Discuss" tab in the "System Settings" ModX.
                Sorry from my english...

                • So you mean this isn't a big problem? I am not sure about your meaning.

                  As I know, the only time this is a problem is when deleting a Discuss user, it causes an error but the user can be deleted.
                  • Have there been any new developments with this? I'm getting the same error "Could not load class: disParticipant from mysql.disparticipant." during installation. I'm running Revolution 2.3.3 and have tried installing Discuss from both the Package Manager and from the Github page linked above. I've also made sure my resource IDs are correct in the system settings.

                    When I try to access a specific board it just displays my site homepage, despite the URL being www.site.com.au/forums/board/1/main-discussion. Friendly URLs are enabled and working for the other pages on the site.

                    I'm also unable to add new User Groups under Extras > Discuss > User Groups. When click the button, nothing happens and this error is displayed in the console: Uncaught TypeError: Cannot read property 'createUserGroup' of undefined

                    I don't know if these issues are related to the error during installation, but I'm not getting any other errors anywhere else.

                    I appreciate any help!
                    • Hi sorry I didn't see your reply to an old post.

                      1. error - probably not a problem. The reason there is no disParticipant list is that the list isn't created until the first front end login, it seems, according to the info of squarou recently.

                      2. This only displays site homepage issue maybe can be fixed by reading this post: http://forums.modx.com/thread/89865/getting-started-htaccess-w-code

                      Wait, when you say site homepage, you mean the forum front page, all forums? If its showing your default page instead, then that seems to be an error and you have it set to go to that page on error, I would think.

                      If this is the case then something isn't letting it display, presumably not related to the user class. There could be a lot of reasons so you would have to go through it all again.

                      3. groups error - hmm thats a new one. Did you try ginzola1's fix? What do you see when clicking on user groups tab? Can you see the forum members and forum moderators listed there? Try using those and see what happens.

                      This function doesn't work very well even in the best case. Some notes:

                      I just posted what I did to define and show user classes in the post view and in the profile view with custom php code
                      I was able to make custom classes through the manager, but they are basically meaningless as they don't seem to really do anything
                      Mods can be set in the system settings, not just in the dialog you are looking at
                      System setting of 'use custom classes' may or may not be relevant
                      Setting up permissions for individual threads and so on is a pain, not sure how well it works, even if you can set up custom classes

                      So all of that is sort of saying, you don't need the manager for this function for the most part.

                      4. Don't forget to go through system settings to get things working, and publish the page that the forum is in.

                      Finally, given that it might be an sql error, could you have an old version of mysql? Dommes89 reported this error but I know he got it running eventually.

                      HTH