We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36570
    • 12 Posts
    Hi everyone,

    I have just installed MODx 2.2.10 Traditional (using web setup install with default parameters) and in the webserver PHP error log I have found this:
    PHP Fatal error:  Class 'xPDODriver_' not found in /home/www/.../core/xpdo/xpdo.class.php on line 1867

    which refers to this part of xpdo.class.php file:
    /**
         * Gets the driver class for this xPDO connection.
         *
         * The driver class provides baseline data and operations for a specific database driver.
         *
         * @return xPDODriver|null An xPDODriver instance for the xPDO connection, or null
         * if a driver class can not be instantiated.
         */
        public function getDriver() {
            if ($this->driver === null || !$this->driver instanceof xPDODriver) {
                $loaded= include_once(XPDO_CORE_PATH . 'om/' . $this->config['dbtype'] . '/xpdodriver.class.php');
                if ($loaded) {
                    $driverClass = 'xPDODriver_' . $this->config['dbtype'];
                    $this->driver= new $driverClass ($this);
                }
                if (!$this->driver) {
                    $this->log(xPDO::LOG_LEVEL_ERROR, "Could not load xPDODriver class for the {$this->config['dbtype']} PDO driver. " . print_r($this->config, true));
                }
            }
            return $this->driver;
        }
    


    Is this a bug?

    I also have errors in the install.config.log:
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/c002cf970fe9237b4dd06b7274044040/0/ to /home/www/.../index.php
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/c002cf970fe9237b4dd06b7274044040/1/ to /home/www/.../ht.access
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/0/ to /home/www/.../manager/assets
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/1/ to /home/www/.../manager/controllers
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/2/ to /home/www/.../manager/templates
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/3/ to /home/www/.../manager/min
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/4/ to /home/www/.../manager/ht.access
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/5/ to /home/www/.../manager/cache.manifest.php
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/6/ to /home/www/.../manager/index.php
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/fb74af2525cf458eb21dd08d0b54f4cf/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/e4fbdd771af2704d3ef22f58e9665157/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/76b2fcba263a8245e1ec4d47c4e8d7c0/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/f06764de434ae5a5e7b8299f51625b7e/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/69ebcad8c88bb8b427d5b0ea0e411f7a/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/6cfb36580a278852fcdd4159b72da55d/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/d1f401e10d5cec8734497895c8802f2b/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/b033806fac318268ce7782f3fbbde8e6/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/0fe162419a98fb4012222b0cc0db2a22/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/151735e612eaa194e50faecf036d7484/ to /home/www/.../connectors/
    [2013-11-13 12:11:21] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/f752c01b0de3c7daa67814d66c5d6954/ to /home/www/.../connectors/
    


    Webserver: Apache
    System: Linux 3.2.41-vch1-amd64 #1 SMP Fri May 17 09:24:31 CEST 2013 x86_64
    MySQL: 5.5.31
    PHP: 5.3.27

    Thanks for your help smiley
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      File permissions, perhaps? How did you upload to the remote server? If you unzipped the MODx download then used FTP to upload all the files, there will often be skipped or corrupted files. The recommended method is to upload the MODx zip file, then unzip in place.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 36570
        • 12 Posts
        Thank you for your attention,

        Yes, I use WinSCP to transfer unzipped files to the webserver. As I use hosting service, how can I unzip in place?
          • 36570
          • 12 Posts
          And just another question, where can I find example of typical files permissions structure, please?
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            Use your hosting control panel's file manager utility to upload the zip file, then unarchive or extract or unzip, whatever it calls the unzipping function. Then, still using the control panel's file management utility, move the root files and folders into their proper place. If using SSH and the command line, make sure to cp or mv recursively.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 28042 ☆ A M B ☆
              • 24,524 Posts
              The permissions needed will depend on your server configuration. Some will require world-writable permissions (777/666), some will require 755/644 permissions.
                Studying MODX in the desert - http://sottwell.com
                Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                Join the Slack Community - http://modx.org
                • 45699
                • 5 Posts
                We too are getting massive install failures under nearly identical circumstances and have exhausted just about every possible remedy that we can conceive of.

                At this point ext-core.js is just throwing a syntax error (Unexpected Token ()) likely because xpdo.class.php is not sending any output...nothing.

                I'm going to wait until the end of the day to tell our client this is a non-starter for us. Maybe they'll be a good lead for someone here smiley

                Anyone have a silver bullet?
                  • 36570
                  • 12 Posts
                  Quote from: sottwell at Nov 13, 2013, 08:27 AM
                  Use your hosting control panel's file manager utility to upload the zip file, then unarchive or extract or unzip, whatever it calls the unzipping function. Then, still using the control panel's file management utility, move the root files and folders into their proper place. If using SSH and the command line, make sure to cp or mv recursively.

                  I went through the installation exactly as you descibed (using webhoster net2ftp utility), but with the same errors, there is no improvement :-(

                  Any other idea?
                    • 36570
                    • 12 Posts
                    Quote from: sottwell at Nov 13, 2013, 08:29 AM
                    The permissions needed will depend on your server configuration. Some will require world-writable permissions (777/666), some will require 755/644 permissions.

                    OK, I use 750/640 as this is the recomended setting on my webhosting service (PHP 5 runs as FastCGI and suEXEC)
                      • 28042 ☆ A M B ☆
                      • 24,524 Posts
                      That should be fine then.
                        Studying MODX in the desert - http://sottwell.com
                        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                        Join the Slack Community - http://modx.org