We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28173
    • 409 Posts
    Hi,

    I have just upgrade on my web server PHP 5.2 to 5.3.10
    On this webserver, I have several websites under Evo and Revo
    All the Revo sites are OK, and some Evo sites too.

    But few Evo website are out of order and I don't know how to repair them.
    I don't know if it's because there a very old (ie. : Evo < 1.0.6 or something like that...), but it's look like database charset and encoding problem (enjoy !)

    The symptoms are :

    • blank front end : no error message, but very slow to load.... nothing !
    • if I go to the manager, I have these errors messages : http://pastebin.archlinux.fr/475215
    • if I try to update Evo to the last 1.0.12 version, I don't have access to the "Upgrade Existing Install" choice : only "Advanced Upgrade". But the system can't access to the database, even with the right password : "Connection failed"

    I'm a little bit disappointed and I really need your help...

    Thanks smiley [ed. note: Spheerys last edited this post 12 years, 10 months ago.]
      • 1343 ☆ A M B ☆
      • 2,213 Posts
      Hello,

      Could you tell us more about your server configuration (ex: MySQL version). The errors in question are pointing towards and older version of MySQL and/or needing to change some configuration settings with it.

      The advanced upgrade only bit would indicate the configuration file was removed / overwritten so it can't do a traditional upgrade.
        Patrick | Server Wrangler
        About Me: Website | Tweets |  MODX Hosting
        • 28173
        • 409 Posts
        Here MySQL version :
        mysql  Ver 14.14 Distrib 5.1.41, for debian-linux-gnu (i486) using readline 5.2


        You said the configuration file was removed / overwritten, but on the filesystem, it's still there, with the right informations inside... [ed. note: Spheerys last edited this post 12 years, 10 months ago.]
          • 20413
          • 2,877 Posts
          Change your config file to exclude the warnings:
          error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT)
            @hawproductions | http://mrhaw.com/

            Infograph: MODX Advanced Install in 7 steps:
            http://forums.modx.com/thread/96954/infograph-modx-advanced-install-in-7-steps

            Recap: Portland, OR (PDX) MODX CMS Meetup, Oct 6, 2015. US Bancorp Tower
            http://mrhaw.com/modx_portland_oregon_pdx_modx_cms_meetup_oct_2015_us_bancorp_tower
            • 28173
            • 409 Posts
            Nothing change :S
            Eternal loading for front end and /manager access.

            On my apache log, I have found an Error 500 when I tried to connect to /manager
              • 28173
              • 409 Posts
              I have found a workaround by moving those problematic websites on an older server and it's working after update them to 1.0.12.
              I have tried to move back one website to the original server but it doesn't works...
              I don't know why and for now, I don't have the time to investigate more over. Later, certainly smiley
                • 20413
                • 2,877 Posts
                Sorry I didn't study your errors tongue

                >> Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file in /var/www/virtual/my-domain.fr/htdocs/manager/includes/extenders/dbapi.mysql.class.inc.php on line 89
                  @hawproductions | http://mrhaw.com/

                  Infograph: MODX Advanced Install in 7 steps:
                  http://forums.modx.com/thread/96954/infograph-modx-advanced-install-in-7-steps

                  Recap: Portland, OR (PDX) MODX CMS Meetup, Oct 6, 2015. US Bancorp Tower
                  http://mrhaw.com/modx_portland_oregon_pdx_modx_cms_meetup_oct_2015_us_bancorp_tower
                  • 13428 ☆ A M B ☆
                  • 1,031 Posts
                  The errors could be caused by this 1.0.9 problem: https://forums.modx.com/thread/?thread=83267

                  The password problem could be caused by wrong cookies and/or browser cache.