We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36570
    • 12 Posts
    Description of Problem:
    After upgrading from MODx Revo 2.2.8 to 2.2.10 the webserver almost on every request returns 503 error. Either on backend (manager) or frontend. If there is not the 503 error, the webpage is loaded only partially and the loading ends up with timeout.

    Tryed to rerun setup for two times, but without any success. There are errors in the install.config.log, please see bellow:
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/c002cf970fe9237b4dd06b7274044040/0/ to /home/www/.../index.php
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/c002cf970fe9237b4dd06b7274044040/1/ to /home/www/.../ht.access
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/0/ to /home/www/.../manager/assets
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/1/ to /home/www/.../manager/controllers
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/2/ to /home/www/.../manager/templates
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/3/ to /home/www/.../manager/min
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/4/ to /home/www/.../manager/ht.access
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/5/ to /home/www/.../manager/cache.manifest.php
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not copy /home/www/.../core/packages/core/modContext/065691d0e4db2ae48028476000a1de3f/6/ to /home/www/.../manager/index.php
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/fb74af2525cf458eb21dd08d0b54f4cf/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/e4fbdd771af2704d3ef22f58e9665157/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/76b2fcba263a8245e1ec4d47c4e8d7c0/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/f06764de434ae5a5e7b8299f51625b7e/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/69ebcad8c88bb8b427d5b0ea0e411f7a/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/6cfb36580a278852fcdd4159b72da55d/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/d1f401e10d5cec8734497895c8802f2b/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/b033806fac318268ce7782f3fbbde8e6/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/0fe162419a98fb4012222b0cc0db2a22/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/151735e612eaa194e50faecf036d7484/ to /home/www/.../connectors/
    [2013-11-02 14:40:23] (ERROR @ /setup/index.php) Could not install files from /home/www/.../core/packages/core/xPDOFileVehicle/f752c01b0de3c7daa67814d66c5d6954/ to /home/www/.../connectors/
    
    



    • MODX Version: 2.2.10
    • PHP Version: 5.3.27
    • Database (MySQL, SQL Server, etc) Version: MySQL 5.5.31

    Thanks for your help.
      • 22840
      • 1,572 Posts
      Firstly, re upload everything as FTP can be a bit hit and miss, secondly FTP into the server and delete everything in the core/cache folder, then clear all cache from your browser and try the upgrade again.
        • 36570
        • 12 Posts
        Hi Paulp,

        thank you for your suggestions. I have re-upgrated according to your guidance and there is some improvement - now I can access the backend without any issues. But it is strange, that the same errors in the install.config.log still remains.

        I also have found out, that when I request some page which contains calls of getPage and nested calls of getResources and getImageList, this throws error to error log (but before upgrading to 2.2.10 it worked well):
        (ERROR @ /index.php) modTemplateVar: Attempt to set NOT NULL field type to NULL

        After this error MODx run into the same problem as described above (very slow frontend and backend, often 503 service unavailable errors)

        Now I am trying to modify the nested calls of getRecourse and getImageList to explore it more.

        I don´t know, whether there is a connection between the upgrade to 2.2.10 errors and nested calls of getResources and getImageList which throws the other error or not.

        Do you have any idea?

        Thanks a lot
          • 22840
          • 1,572 Posts
          can you give an example of getPage and the nested calls of getResources and getImageList you are using ?

          Also does putting a call in a template give the correct result ?
            • 36570
            • 12 Posts
            Hi Paulp,

            yesterday I just went through my template chunks of getResources and getImageList. I only delete some white spaces and some linebreaks, no other chganges. Actually, there is one change in the element´s editor - now I use Ace (before it was Code Mirror) Till that moment I can not reproduce the error:
            (ERROR @ /index.php) modTemplateVar: Attempt to set NOT NULL field type to NULL


            And the website is running correctly...

            Thanky for your help.