Oh Susan, you genius you! Thank you so much, this "bug" has been bugging me for months. It turns out I had a faulty link in the content of the 404 page – [[~sitestart]]. (Yes, faulty in so many ways... *blushing*)
You made me realise the link should obviously be [[~[[++site_start]]]].
Very odd that the system throws up errors on every single page when the only error is in the 404 page, but I'm guessing there's a very good reason for that. Cache related perhaps. Who cares, I'm over the moon!!!!!!
Hugs!