We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40833
    • 52 Posts
    PHP: 5.3.24
    MySQL: 5.5.19
    Apache: ?
    Host: GoDaddy (yuck)
    MODx: 2.2.9

    Yesterday I installed TinyMCE in 2.2.8 and I got some errors (permission errors I think, didn't write them down unfortunately). When I refreshed the site, it went completely blank - front end AND manager. I didn't panic because I knew that deleting the cache files will usually fix this problem. Except, it didn't this time. GoDaddy's imbecilic setup requires that you enable error reporting, and then wait 24 hours to have access. When I looked today, there was nothing that helped (of course because the errors would have occurred before when I installed the package).

    I tried to upgrade to 2.2.9, and the only setup config error I got was a permissions problem on the core/config file, so once I set proper permissions, the upgrade went smooth. Once again, no love.

    When I delete the cache files and refresh the site, it builds action_map, context_settings, lexicon_topics, mgr and system_settings (and stops there).

    Otherwise I have no clues, no errors, nothing to point me in the right direction. Of course GD support denies there is anything wrong with their server (except it took me 30 mins to login this morning due to system errors, connection resets, and general crap slowness).

    The client is being stubborn and feels like this is not a GoDaddy issue, though I've seen literally dozens and dozens of posts on here saying otherwise.

    ANY help would be greatly appreciated. I don't even know where to begin to fix this problem except to start over with a fresh install. Do you think manually uninstalling TinyMCE my help, and if so, tips on how to do this?

    Thanks in advance ~ Dan

    (edited 12/18/2013 to make title more concise to the topic) [ed. note: dan971 last edited this post 12 years, 9 months ago.]
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Go into the database, and in the site_plugins table find the row for TinyMCE and set its disabled field to 1. You'll probably need to delete the core/cache directories again.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 40833
        • 52 Posts
        Quote from: sottwell at Oct 11, 2013, 03:32 PM
        Go into the database, and in the site_plugins table find the row for TinyMCE and set its disabled field to 1. You'll probably need to delete the core/cache directories again.

        Thanks for the tip - but no go. I'm getting ready to move the site to a different (testing) server to see if that resolves it. I'll post an update when I'm finished.
          • 40833
          • 52 Posts
          [SOLVED] Okay, so, it was GoDaddy, but in an indirect way. What happened was, when I updated the package fastField, somehow it must have got corrupted in either the download or unpacking process to GoDaddy's server. The biggest problem came from the fact that the CMS would create the cache files up to but NOT including the error.log files, so I had no clues from which to start this whole grande investigation.

          What finally tipped me off was installing it on a different server and getting the same "blank page" problem. This meant that some files or data in the db must have become corrupted when I updated the plugins, and since I only updated two plugins (fastField and TinyMCE), I had a good starting point from there to work backwards. After fiddling around in the database trying to disable the package, and also deleting the components and packages files, it finally created the error.log file, and from there, I saw a fastField error.

          I hope this was just a fluke, because this has never happened before to me.
            • 28042 ☆ A M B ☆
            • 24,524 Posts
            Yes, I can see where a bad fastField installation would cause some serious problems. It uses a fairly new feature (since 2.2.7) allowing an extended modParser, so it basically takes over the entire parsing process to provide for the new tag type ([[#...]]).
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 40833
              • 52 Posts
              Well, I hope this doesn't happen again or become an issue in the future, because I really, really like that plugin. Thanks!