This problem seems to be fixed. After much trial and error, for some reason one of the things i tried was to remove a certain 301 redirect from the .htaccess file which was-
RewriteCond %{HTTP_HOST} ^sovereignsailing\.com$ [OR]
RewriteCond %{HTTP_HOST} ^www\.sovereignsailing\.com$
RewriteRule ^index\.php$ "http\:\/\/www\.sovereignsailing\.com\/" [R=301,L]
And then once this was removed, after much cache clearing and page refreshes, the ?q= character disappeared from all url's! Also, now the redirector plugin seems to be working. Not sure what the significance of removing this redirect was, i suspect it's something to do with the index.php part...
And the reason i put it in the .htaccess in the first place was because it was flagging up in google webmaster tools as a url that couldn't be found (so i thought i'd 301 it as per all the other 'old' urls). Anyway, case solved for now