On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I realise this is probably a server issue but I hope someone else has experienced something similar...

    If I connect to my Revo 2.2.6 site using: <ip address>/<site>/manager I get the normal login page. No problem.

    If I connect using <url>/manager I still get the login page but it is now text only.

    Why??

    The source for both pages are identical. I have checked as best I can the server side apache configuration (it is a Ubuntu 11.10 server). I guess it is a permissions issue but I can't see anything wrong.

    Any help would be appreciated.

    Robert.
    • I think it's more likely a path issue rather than permissions. I'd try running Setup from <url>/manager. That may straighten out the paths. If that doesn't work, try turning off the compress_js and compress_css System settings.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • Thanks for the suggestions BobRay. I turned off the settings and also (separately) upgraded to 2.2.10 (following your FAQ - much better than the doco - thanks) from <url>/setup. Same problem - <url>/manager is text only and <ip address>/<site>/manager works fine. Any other thoughts??

        Just in case it helps, this is what the <url>/manager login screen looks like:

        [ed. note: gissirob last edited this post 7 years, 11 months ago.]
        • stalemate resolution associate Reply #4, 7 years, 11 months ago
          Hi gissirob,

          As they say, a picture is worth a thousand words. It looks like your css isn't loading. I use Firefox, and in Firefox, you can right click on a page and view source.

          When you view the source, you should see a list near the top like this:

          <link rel="stylesheet" type="text/css" href="/manager/assets/ext3/resources/css/ext-all-notheme-min.css" />
          <link rel="stylesheet" type="text/css" href="/manager/templates/default/css/xtheme-modx.css" />
          <link rel="stylesheet" type="text/css" href="/manager/templates/default/css/index.css" />
          <link rel="stylesheet" type="text/css" href="/manager/templates/default/css/login.css" />
          


          Since this is the login page, and login is the last css on the list, it would seem like a good idea to see if you can get to that link. I see that in the source being generated, there is no base url, so I assume that this is relative to the root of the site.

          In Firefox, it has the href values highlighted, and when I click on them, I can see the source. Check to see if you have permissions to see those files and that the files are in the expected location.

          Hope this helps.
          • Thanks sra, you've hit the nail on the head. I now know why it's not working, just not how to fix it. This is an extract of my source:

                <link rel="stylesheet" type="text/css" href="/hca/manager/assets/ext3/resources/css/ext-all-notheme-min.css" />
            	<link rel="stylesheet" type="text/css" href="/hca/manager/templates/default/css/xtheme-modx.css" />
            	<link rel="stylesheet" type="text/css" href="/hca/manager/templates/default/css/index.css" />
                <link rel="stylesheet" type="text/css" href="/hca/manager/templates/default/css/login.css" />
            
                    <script src="/hca/manager/assets/ext3/adapter/ext/ext-base.js" type="text/javascript"></script>
                <script src="/hca/manager/assets/ext3/ext-all.js" type="text/javascript"></script>
                    <script src="assets/modext/core/modx.js" type="text/javascript"></script>
            
                <script src="assets/modext/core/modx.component.js" type="text/javascript"></script>
                <script src="assets/modext/util/utilities.js" type="text/javascript"></script>
            	<script src="assets/modext/widgets/core/modx.panel.js" type="text/javascript"></script>
                <script src="assets/modext/widgets/core/modx.window.js" type="text/javascript"></script>
                <script src="assets/modext/sections/login.js" type="text/javascript"></script>
            


            So here's my question: why are the first 6 link / script references fully qualified, and the next 6 relative (the last 6 work when I click through as you suggest, the first 6 do not). Surely whatever setting is used to generate these links should do so consistently? And how do I fix this??
            • Log in via FTP and edit the core.config.php file in the config folder, make sure that all the paths are correct in there as it looks like the manager path is wrong
              • Thanks everyone for your help - all working now. This is what I did to fix it:

                1. Edited the core/config/config.inc.php file (after making it writable).

                2. Changed the following 4 lines:
                $modx_connectors_url= '/connectors/';
                $modx_manager_url= '/manager/';
                $modx_base_url= '/';
                $modx_assets_url= '/assets/';

                from /<site>/<manager, assets etc (as above)> to what you see above. That is, I removed the site directory name.

                3. Make the file readonly again so the dashboard stops telling me it is writable.

                Did I need to change all 4 lines? I'm not sure but I figured best to be consistent. If anything blows up down the track, I'll update.

                And finally, just to recapitulate: the reason (I think) that this problem occurred in the first place was that I originally installed Revo before I had a domain name (ie it was installed using <ip addreess>/<site>/setup) and the install picked up the <site> and put it in the config file. Even after doing an upgrade using <url>/setup, the <site> was not removed. Hence the manual edit of the file. Hope this helps someone else.
                • Ok here is what worked for me, My setup location was at d:\wamp\www\modx\ and my settings were

                      $modx_manager_url= '/manager/'; 


                  Front end was working fine but manager css was missing with wrong path, 404.

                  So i added modx/ to the settings and it worked

                    $modx_manager_url= '/modx/manager/';


                  I edited other settings also and added directory name "modx"
                  $modx_connectors_url= '/modx/connectors/';
                  $modx_manager_url= '/modx/manager/';
                  $modx_base_url= '/modx/';