We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21417
    • 486 Posts
    Hello,

    Every time I log into the Evo 1.0.12 manager, I get an email saying important system files have been modified.

    Subject: Error mail from NAME-OF-MY-Site
    Important System Files have been modified.
    I am also getting logged out quite regularly.
    I presume this is related to settings in Tools > Configuration > User.

    Any ideas how to adjust this, but keep the security checking in place? I don't mind the check when someone logs in, but the wording of the email is a pretty vague.

    Logging into the manager is not an exactly error.

    In "Check core files on login", I have:
    index.php
    .htaccess
    manager/index.php
    manager/includes/config.inc.php

    In "Detection level of the PHP error", I have:
    Ignore the warning of a slight notice level

    In "email notifies system error.", I have:
    error
    (I also tried "error + warning + information" but this did not change the error message to something more meaningful in the email or the event log.

    Thanks in advance.
      Web design Adelaide
      http://gocreate.com.au
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      That's not an error from logging in. Evo checks certain files, like the index.php files and the config.inc.php file, and if these have changed then it makes this warning. I think that there is a way to have it accept the latest version of the files as good and stop with all the messages, unless the files get changed again.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 21417
        • 486 Posts
        Thanks Sottwell.

        I think that there is a way to have it accept the latest version of the files as good and stop with all the messages, unless the files get changed again.

        That would be nice. Do you know where / what that setting is?

        Evo is generating a lot of error messages but those files have definitely not changed - the only thing that happened was me logging in. And every time I do that I get the error email.

        The wording in the email is vague - if it said username logged in or the details of the error it would be different.
          Web design Adelaide
          http://gocreate.com.au
          • 9995
          • 1,613 Posts
          Configuration > User > email notifies system error

          I had the same problem.
            Evolution user, I like the back-end speed and simplicity smiley
            • 21417
            • 486 Posts
            Thanks fourroses666.
            That was actually the setting I had it set on.
            Funny thing is I haven't had any of the error emails today and there is nothing showing in Reports > System events either.
            I like that it is not happening, but not sure what has changed.

            Another thing I note is that when opening Elements for example in a new tab, or viewing Reports > System Info > phpinfo, I get logged out of the manager after a short amount of time (maybe 1 minute or so). That must be a new security setting?
              Web design Adelaide
              http://gocreate.com.au
              • 9995
              • 1,613 Posts
              Hmm, I don't have that problem. If you find any bugs the best is to report it on bugtracker I think.
                Evolution user, I like the back-end speed and simplicity smiley
                • 21417
                • 486 Posts
                Viewing Reports > System Info > phpinfo is not logging me out today either when looking in the same tab - I think its more related to viewing evo components in multiple tabs and not sure if its a bug or just a setting somewhere.

                Thanks all for your input.
                  Web design Adelaide
                  http://gocreate.com.au