On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi,

    I've inherited an old Windows Server 2003 IIS6 machine. Hoping to upgrade when the contract runs out in a few months but want to impress a client with MODx before then.

    I managed to install Revolution 2.2.9 and initially had trouble with the installation stopping at the transport package unzipping.

    The install failed because MODX could not unpack the C:/_WebSites/SeeIT/SCSN/revo/core/packages/core.transport.zip package. Make sure that the C:/_WebSites/SeeIT/SCSN/revo/core/packages/core.transport.zip file exists and is writable, and that you have made the C:/_WebSites/SeeIT/SCSN/revo/core/packages/ directory writable.


    But by lots of messing (and guessing) with IUSR_Servername permissions and properties and all sorts I managed to get around that. Installation worked and I was able to install packages.

    Great - apart from too much guesswork.

    Sad Part - I can't Upload Images.

    The Upload dialog appears to work. OK message and the feedback messages which shows progress count ( 0 of 1 etc) switches to "Waiting". But no images.


    Tried endless messing with IIS Properties (read/write/Execute Permissions), NTSF Properties - Security, Groups and User Names, Network Service/Users/FTP Users/Internet Guest Accounts/IUSR_Servername, Special Permissions, Inherited From, Apply To combinations of Folders, Subfolders and Files only in order to replicate the 644 or and 777 stuff. Effective Permissions, Advanced Security Settings, Inheritable Permissions from Parents (on and off) and more. Yikes. Can Linux really be 777 and 664 or similar variants to replace all that lot?

    Tried to be logical but no joy. Given that I can add packages why would upload images fail? Also tried Deprecated MODx System Settings in Area: File System which the notes suggest can be useful for IIS.
    (Files are small, and tried making the images folder using modx

    Should really just give up but as Macbeth put it "I am in blood, stepped in so far that, should I wade no more, returning were as tedious as go'oer".

    • Given that I can add packages why would upload images fail?

      Packages go into core/packages/ and typically install into assets/components/ and core/components/ - I have zero experience with IIS (I tried once), but it may be something applied on the folder level if packages work but image uploads fail.
        Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

        Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.