We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 44095
    • 10 Posts
    christianwalker Reply #1, 13 years ago
    I was able to run setup on a modx site migration installation, but when I did and went to manager it gave me a blank screen. I had no errors and I have already tried deleting my cache folder. I have also look at the troubleshooting documentation for help but I've had no luck.

    Any suggestions?

    Thanks!
      • 3749
      • 24,544 Posts
      You don't say what else you tried. Here are some other options:

      Clear your browser cache and cookies.
      Turn off the compress_js and compress_css System Settings in the modx_system_settings table in PhpMyAdmin.
      Check the paths and URLs in the core/config/config.inc.php file.
      Check the path in the three config.core.php files (root, manager, and connectors directories).
      Check the path in the modx_workspaces table.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 10525
        • 247 Posts
        I'm getting this same issue.

        Revo 2.2.13

        I upgraded several weeks ago and have been able to login ok, until 2 days ago.

        I get the manager login screen but after entering details and submitting, just get a white screen. No error message.

        Bob, I've run through your list of suggestions above and a couple of questions:

        1. Manager should work in incognito/private browser mode, yes?
        2. The entry in my modx_workspaces table is simply "{core_path}". Is that correct?

          • 10525
          • 247 Posts
          I deleted my cache/error.log file, refreshed the blank 'manager' screen and content of error.log is now:

          [2014-05-21 11:09:33] (ERROR @ /index.php) context for 68 is web
          [2014-05-21 11:09:33] (ERROR @ /index.php) SELECT `modResource`.`id`, `modResource`.`type`, `modResource`.`contentType`, `modResource`.`pagetitle`, `modResource`.`longtitle`, `modResource`.`description`, `modResource`.`alias`, `modResource`.`link_attributes`, `modResource`.`published`, `modResource`.`pub_date`, `modResource`.`unpub_date`, `modResource`.`parent`, `modResource`.`isfolder`, `modResource`.`introtext`, `modResource`.`content`, `modResource`.`richtext`, `modResource`.`template`, `modResource`.`menuindex`, `modResource`.`searchable`, `modResource`.`cacheable`, `modResource`.`createdby`, `modResource`.`createdon`, `modResource`.`editedby`, `modResource`.`editedon`, `modResource`.`deleted`, `modResource`.`deletedon`, `modResource`.`deletedby`, `modResource`.`publishedon`, `modResource`.`publishedby`, `modResource`.`menutitle`, `modResource`.`donthit`, `modResource`.`privateweb`, `modResource`.`privatemgr`, `modResource`.`content_dispo`, `modResource`.`hidemenu`, `modResource`.`class_key`, `modResource`.`context_key`, `modResource`.`content_type`, `modResource`.`uri`, `modResource`.`uri_override`, `modResource`.`hide_children_in_tree`, `modResource`.`show_in_tree`, `modResource`.`properties` FROM `modx_site_content` AS `modResource` WHERE ( ( modResource.parent IN (68,147,116,137,138,37,41,43,39,115,40,42,38,44,45,46) AND `modResource`.`deleted` = 0 AND `modResource`.`published` = 1 AND `modResource`.`hidemenu` = 0 ) AND `modResource`.`template` = 15 ) ORDER BY menuindex ASC LIMIT 5
            • 10525
            • 247 Posts
            Just for curiosity, I tried it in IE8 and got an HTTP 500 Internal Server Error:
            The website cannot display the page
            HTTP 500
            Most likely causes:
            •The website is under maintenance.
            •The website has a programming error.
              • 10525
              • 247 Posts
              OK, this is solved.

              I got this in my Plesk error_log:
              [Wed May 21 12:16:36 2014] [warn] [client xx.xx.xx] mod_fcgid: stderr: PHP Parse error: syntax error, unexpected '<' in /var/www/vhosts/mydomain.com/httpdocs/manager/controllers/default/footer.php on line 14, referer: http://mydomain.com/manager/

              Inside the footer.php file I had this:
              <?php
              /**
              * Loads the footer
              *
              * @package modx
              * @subpackage manager.controllers
              */



              <script language="javascript">

              </script>
              So, a hack.

              There are several files with dates on a day I did not access the site or manager.

              I will upgrade to 2.2.14 to clean up.