So... I fixed the friendly URLs issue (failed to reload apache config after adding the rewrite module DUH). But I'm still interested to know why I'm unable to run the installer on this virtual machine:
Digital Ocean Ubuntu 12.04 LTS Box running apache2 and PHP 5.3.10-1ubuntu3
If there are any good Linux guys out the I'd really appreciate the help, I'm very new to Linux and server admin in general and barely treading water
Cheers
Ash
-
☆ A M B ☆
- 3,141 Posts
is the core/packages/core directory writable too? It probably already exists; you could try removing it so it gets extracted again.
-
MODX Staff
- 1,535 Posts
Check you have the Zip PHP module installed and, I'm not sure if this would be required, but maybe install unzip: apt-get install unzip
Other than that, could still be permissions, double check those. I know my DO box uses www-data as the user, so chown your MODX directory (files and folders) to www-data:www-data and chmod files to 0664 and folders to 0775.
Not near my laptop to run through an Apache setup to confirm - let me know of you have further issues though.
Garry Nutting
Senior Developer
MODX, LLC
Email:
[email protected]
Twitter: @garryn
Web: modx.com
Its definitely not permissions and unzip is installed on the server however the zip PHP module sounds like it is likely the problem because I get the same issue with a fresh install on this Box. Cheers Gary!
Ash
Replying to you all about the issue related to folder permissions when installing MODX.
The solution I pointed out, of deleting the CORE directory in the PACKAGES directory fixes the problem. The reason for this issue is related to PHP run as mode. It should all be installed on PHP FastCGI mode. If you install it on APACHE mode, you will run into this kind of file permission issues.