We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 30585
    • 833 Posts
    I'm trying to run an upgrade from 2.2.6 to 2.2.7 to fix a manager login issue, but I get a 404 error when I run the install (mysite.com/setup). In other words, mysite.com/setup is cannot be found, but all other directories in the site can be listed. I've uploaded the new files a few times already, but no... I also checked folder permissions and they're 755.

    I should mention that I was forced to run the upgrade because I couldn't login to the manager. I was getting this error when I open the manager page:

    Warning: include_once(/hsphere/local/home/xxxxx/mysite.com/core/model/modx/modx.class.php): failed to open stream: No such file or directory in /home/lgctvorg/public_html/manager/index.php on line 50

    Warning: include_once(): Failed opening '/hsphere/local/home/xxxxx/mysite.com/core/model/modx/modx.class.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mysitecom/public_html/manager/index.php on line 50

    Warning: include(/hsphere/local/home/xxxxx/mysite.com/core/error/unavailable.include.php): failed to open stream: No such file or directory in /home/mysitecom/public_html/manager/index.php on line 51

    Warning: include(): Failed opening '/hsphere/local/home/xxxxx/mysite.com/core/error/unavailable.include.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mysitecom/public_html/manager/index.php on line 51
    Site temporarily unavailable!

    Any idea what's going on here?

    This question has been answered by treigh. See the first response.

      A MODx Fanatic
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      What do your three core.config.php files (one in the site root, one in /connectors/ and one in /manager/) say? Are they pointing to the correct paths to the core?
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 30585
        • 833 Posts
        Thanks Sottwell.

        It's very strange. All 3 files are almost useless. This is what I have in all 3 of them:

        <?php
        define('MODX_CORE_PATH', dirname(dirname(__FILE__)) . '/core/');
        define('MODX_CONFIG_KEY', 'config');
        


          A MODx Fanatic
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          Hm. You might want to edit those to actually be the full path to your core. For example, on my MAMP local server, I have
          define('MODX_CORE_PATH', '/Applications/MAMP/htdocs/revo228/core/');
          define('MODX_CONFIG_KEY', 'config');
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 30585
            • 833 Posts
            I did on all 3 files, but the issue is still here. Any thoughts?
              A MODx Fanatic
              • 28042 ☆ A M B ☆
              • 24,524 Posts
              Check the config.inc.php file very carefully. It's easy to miss a path or URL in there.

              If you're sure that all paths and URLs are correct, the cache has been manually cleared (delete all folders under /core/cach/) then check to make sure that the files are in fact where they're supposed to be. And clear your browser cache and cookies for the domain.
                Studying MODX in the desert - http://sottwell.com
                Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                Join the Slack Community - http://modx.org
                • 3647
                • 177 Posts
                Could not add to what sottwell says, but in case this helps:

                the place your manager login is failing is:

                /* include the modX class */
                if (!(include_once MODX_CORE_PATH . 'model/modx/modx.class.php')) {
                include MODX_CORE_PATH . 'error/unavailable.include.php';
                die('Site temporarily unavailable!');
                }

                which definitely implies your MODX_CORE_PATH is wrong, question is... what is it now?

                have a look at config.core.php in the manager directory and see what is says, I would guess you need

                <?php
                define('MODX_CORE_PATH', '/home/xxxxxxxx/public_html/core/');
                define('MODX_CONFIG_KEY', 'config');
                ?>
                replacing xxx with your domain without the '.'
                  • 3749
                  • 24,544 Posts
                  Check the config.core.php file in your setup/includes directory.
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                  • discuss.answer
                    • 30585
                    • 833 Posts
                    Thanks all for the feedback.


                    As it turns out, the site owner upgraded their hosting from Shared to some virtual Cloud package and I wasn't aware of this. I guess I was looking for the living among the dead.

                    It's all good now.

                    Sorry for the time I helped you waste.
                      A MODx Fanatic