I'm in the process of trying to replicate my 'live' site to another domain on my shared server.
I've edited a revised version of the config.inc.php with the correct db settings and paths but for some reason I'm being prevented from uploading it to the server, failing both via ftp or the file manager in cpanel. It looks like something on the server is blocking it.
Is there any reason this would be blocked by the modx install ?
Also can some one suggest appropriate folder permissions to upload and for once it's sorted ?
Many thanks
David
644 should allow you to overwrite or edit it, change it back to 444 when your done.
-
☆ A M B ☆
- 2,475 Posts
Blocking the upload? That does not sound at all normal. Are you uploading a zip file and extracting on the server?
Permissions requirements vary from server to server, so you may need to experiment. If 444 doesn't work, try 644, then 664. If things are still not working, you can venture into 755 and 775, but that's a last resort. You should get some errors in your PHP or Apache logs to help you out.
Everett For the config.inc.php file I was just ftp'ing a single file to the server. No zip, although I had zipped and unpacked the public html folder when I replicated the site and then uploaded the mysql backup. The .htaccess uploaded ok to the public_html root.
willyps, Thanks - I'll look at it again and have a play.
- update - The core/config folder was already set to 755.
It turns out that it was an issue with the server and I can now upload ok.
[ed. note: alchemy last edited this post 13 years, 1 month ago.]
-
☆ A M B ☆
- 2,475 Posts
What's the exact message you're getting when the upload gets blocked?