We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 39389
    • 9 Posts
    Hallo People,
    i dont know what really happens

    This MODX Revo 2.2.8 hosted on 1and1 with PHP Version 5.4.17 is complete down after I updated or try to update FastField to the newest version in the manager.

    There were some errors but i cant say now wchich one because after refreshed the site i got this error
    in the frontend and also in the backend.

    Fatal error: Class 'modParser' not found in /homepages/34/d253685824/htdocs/weddingCMS/core/components/fastfield/model/fastfield/fastfieldparser.class.php on line 2


    and this is the code in the line 2
    class fastFieldParser extends modParser { 


    I dont know why i cant access the manager ?
    Ive talked to the customer an he means at the same time he changed only the FTP Password in the 1and1 backend.

    i dont think that this causes this error but i also dont really belive to the customer that he know what he done there.

    What can i do to find the error ?

    Please help because the customer means its my and the foult of modx smiley
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      First, use your FTP client and go to core/cache/ and delete all the folders under core/cache (don't worry, MODx will build the cache again).

      If this doesn't help, uninstall all versions of FastField, then remove it, then download and install it again.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 39389
        • 9 Posts
        Quote from: sottwell at Jul 29, 2013, 06:24 AM
        First, use your FTP client and go to core/cache/ and delete all the folders under core/cache (don't worry, MODx will build the cache again).

        If this doesn't help, uninstall all versions of FastField, then remove it, then download and install it again.

        Thanks for the answer
        ive tried to empty the core/cache folder.

        The problem is that the MANAGER BACKEND shows me the same error.

        So I cant uninstal this plugin.

          • 39389
          • 9 Posts
          Hmm i hope I solved it,
          I think it was because the FastField plugin.

          I found in the core/cache the settings folder an edit on the bottom in the config.cache.php

           
           /* 'parser_class' => 'fastFieldParser',
            'parser_class_path' => '/homepages/34/d253685824/htdocs/weddingCMS/core/components/fastfield/model/fastfield/', */
          );


          so i saw the site with the cached settings without the path to the parser class.
          The backend was also there again.

          Ive logget me in and uninstalled this Extension "FastField" but if i cleared the cache was the same problem there.

          In the readme of this Plugin

          fastField 1.3.0-pl
          -------------------
          - Totally replace modParser by fastFieldParser
          - Cache resource fields