Installed Flexibility 4 on Modx Cloud Updated Articles and Quip Packages Names First Letter Capitalised seems Ok
Installed Flexibility 4 on localhost in folder revo Updated Articles and Quip Packages but duplicate entries on both packages one First Letter Capitalised other all lower case seems Strange.
Regards
Allan
DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31
-
☆ A M B ☆
- 1,780 Posts
That seems to happen with Flexibility packages. In the past, I've just deleted all the package entries entirely and reinstalled from Package Management. I've not seen it with Quip and Articles yet though, just MIGX.
Package management keeps all the old versions of any package in the packages folder, if they don't match in case, then you could see two. Deleting them all, and reinstalling is a safe option IMO. That way you only have the most recent, which does not interfere with Flexibility. Flexibility installing the packages for you is a convenience, and in no way means that you have to use the versions that come with it.
It's possible that Flexibility doesn't properly check the currently installed versions of extras against the ones it tries to install. That would give you the collision error message and the install of the extra subpackage would fail, but I don't think it would hurt anything.
Thanks @BobRay & @Frogabog
I will delete and try new install on localhost.
All seems good on MODX Cloud
Regards
Allan
DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31
The uppercase/lowercase problem with package names is a perennial problem, and so is subpackages installed by another extra. I'd created dozens of packages and I still don't know the best way to handle the case issue.
Another problem is that the "provider" field is hard-coded as 1 when subpackages are installed. If you mess with changing providers in Package Manager, you can easily end up with the MODX repo having some other ID. All kinds of weird things will happen and your error log will be continually crapped up.
I second Frogabog's suggestion to uninstall and remove the subpackages in PM (ignore any error messages).
You may need to remove some packages more than once and repeat the operation for multiple versions.
Do a "Search Locally for Packages" as a last step to make sure that none of them are still there.
Then, download and install the subpackages through Package Manager. You may see some error messages during the install, but hopefully, you'll be better off.
Many thanks @BobRay.
Do you suggest I remove ALL installed packages by Flexibility 4 and re-install from packet management as I may need to update others at some future date?
Regards Allan
DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31
-
☆ A M B ☆
- 1,780 Posts
It's not going to hurt to remove and reinstall all the packages, but maybe for the moment just worry about the ones that are duplicated or in lower case.
Normally I don't have issues with upgrading Flexibility packages, but some are more troublesome than others such as MIGX and Articles. Normally I uninstall both of those and reinstall immediately to save future headaches. I also haven't tested Flexibility 4 much, and it's a completely new build as far as I can tell. It could very well behave differently than previous builds.
Thank you @Frogabot.
I thought all lowercase was the normal I was more worried about the first letter Capitalized in the duplicate packages.
I will uninstall Articles, Quip and MIGX and report back
Regards
Allan
DEVELOPMENT ENV:- Ubuntu 12.04 | MODx Revolution 2.2.8 | LAMP 2i Apache 2.2.22 | Php 5.3.10 | Mysql 5.5.31 MySQL client version: 5.5.31